Bug 1373063 - instack-virt-setup: disable unwanted repos
Summary: instack-virt-setup: disable unwanted repos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 10.0 (Newton)
Assignee: Ben Nemec
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-05 04:02 UTC by Faiaz Ahmed
Modified: 2016-12-14 15:56 UTC (History)
9 users (show)

Fixed In Version: diskimage-builder-1.21.1-0.20161008070214.3c1f82d
Doc Type: Bug Fix
Doc Text:
Cause: See BZ detail. Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:56:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Faiaz Ahmed 2016-09-05 04:02:08 UTC
Description of problem:
Need to know how to disable all unwanted repos.

Version-Release number of selected component (if applicable):

~~~~~~~~~~~~~~~~~~
$ rpm -qfi /bin/instack-virt-setup
Name        : instack-undercloud
Version     : 4.0.0
Release     : 13.el7ost
Architecture: noarch
~~~~~~~~~~~~~~~~~~

How reproducible:


Steps to Reproduce:
Following the doc 
https://access.redhat.com/articles/2534191

~~~~~~~~~~~~~~~~~
5. Set the environment variables for RHN:
$ export REG_METHOD=portal
$ export REG_USER=rhn-support-XXXXX
$ export REG_PASSWORD=**********
$ export REG_POOL_ID=XXXXXXXXXXXXXX
$ export REG_REPOS="rhel-7-server-rpms rhel-7-server-extras-rpms rhel-7-server-openstack-9-rpms rhel-7-server-openstack-9-director-rpms rhel-7-server-rh-common-rpms"
~~~~~~~~~~~~~~~~~

And then 
$ instack-virt-setup

But as result it end up with error because some unwanted repos been enable and which no longer available.

~~~~~~~~~~~~~~~~~~
++ find /tmp/in_target.d/pre-install.d -maxdepth 1 -name 'package-installs-*'
+ '[' -n '' ']'
WARNING: map-packages is deprecated.  Please use the pkg-map element.
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/fast-datapath/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article 

https://access.redhat.com/articles/1320623

Like yum-config-manager --disable rhel-7-fast-datapath-rpms
~~~~~~~~~~~~~~~~~~

So, would like to know if there is any option disable all the unwanted repos.

FYI, it can be done using subscription manager but will not help as its pass to the overcloud images.


Actual results:


Expected results:


Additional info:

Comment 6 Ben Nemec 2016-10-14 16:21:58 UTC
Oh, actually it's already merged: https://review.openstack.org/#/c/377331/

Comment 7 Dmitry Tantsur 2016-10-17 09:20:25 UTC
Please someone backport the change to OSP 10.

Comment 10 Ben Nemec 2016-11-21 22:04:44 UTC
Moving to verified as this is a dev/test bug only so there's no sense wasting QE time verifying it.  If any developers or testers find that it's not actually fixed they can reopen.

Comment 12 Ben Nemec 2016-12-13 19:08:25 UTC
instack-virt-setup is not a supported tool for customer use.  We shouldn't need to document any fixes to it.

Comment 14 errata-xmlrpc 2016-12-14 15:56:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.