Bug 137307 - Cannot show hidden columns in calc
Summary: Cannot show hidden columns in calc
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-27 13:41 UTC by JLapham
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 14:21:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description JLapham 2004-10-27 13:41:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Hidden columns cannot be unhidden.  This only affects "Sheet2" and
"Sheet3" but not "Sheet1".

Workaround:
If you move "Sheet2" to before "Sheet1", you can show hidden columns.


Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-10.fc2

How reproducible:
Always

Steps to Reproduce:
1. open a new spreadsheet (using OOo 1.1.1) and hide the "B" column. 
This column can be unhidden by highlighting the "A" and "C" columns
and selecting "show" from the right-mouse click menu.

2. Now, go to "Sheet2" and repeat the steps above.  You cannot show
the "B" column.  
    

Actual Results:  The column "show" option is not available

Expected Results:  Show the hidden columns

Additional info:

Apparently this bug does not exist in the stock OOo v1.1.2.  It does,
however, exist in the Debian version of OOo.  This bug existed in the
earlier versions of OOo for FC2 (v1.1.1).

I would deem this bug severity "high", because you cannot retreive the
data that is in a hidden column.

My original OOo bug report:
http://www.openoffice.org/issues/show_bug.cgi?id=30517

A Debian bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=Bug%23278501

Comment 1 Dan Williams 2004-11-02 20:56:15 UTC
Problem appears to be sc-show-sensitize.diff in ooo-build, where the
Tab # isn't being propogated down the "is this row/col hidden" check,
so its effectively only checking the first sheet for hidden stuff.


Comment 2 Dan Williams 2004-11-02 21:33:12 UTC
Should be fixed in 1.1.2-11


Comment 3 Dan Williams 2004-11-11 14:21:31 UTC
Should be fixed now.

Comment 4 JLapham 2004-11-17 19:22:48 UTC
Yup, works for me using the latest errata update.

openoffice.org-1.1.2-11.5.fc3


Note You need to log in before you can comment on or make changes to this bug.