Bug 1373129 - dracut-install: ERROR: installing '/etc/hba.conf' to '/etc/hba.conf'
Summary: dracut-install: ERROR: installing '/etc/hba.conf' to '/etc/hba.conf'
Status: CLOSED DUPLICATE of bug 1369342
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut   
(Show other bugs)
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Bruno Goncalves
Lenka Špačková
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-05 10:00 UTC by Bruno Goncalves
Modified: 2017-04-06 14:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
*dracut* displays a harmless error message about a non-existent `/etc/hba.conf` When *dracut* creates an initial RAM file system (initramfs) with Fibre Channel over Ethernet (FCoE) support, if the `/etc/hba.conf` file does not exist, *dracut* displays an error message. You can safely ignore this message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-06 14:17:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Goncalves 2016-09-05 10:00:45 UTC
Description of problem:
When running dracut --force on a server with soft FCoE card the following error is show:

dracut-install: ERROR: installing '/etc/hba.conf' to '/etc/hba.conf'
/usr/lib/dracut/dracut-install -D /var/tmp/dracut.Qc7mrc/initramfs /etc/hba.conf /etc/hba.conf


Version-Release number of selected component (if applicable):
dracut-033-458.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.run "dracut --force" on a server with soft FCoE enabled
2.
3.

Actual results:
# dracut --force d
mmap: Invalid argument
dracut-install: ERROR: installing '/etc/hba.conf' to '/etc/hba.conf'
/usr/lib/dracut/dracut-install -D /var/tmp/dracut.Qc7mrc/initramfs /etc/hba.conf /etc/hba.conf


Expected results:
No error message should be shown

Additional info:

## hba.conf does not exist

# ls /etc/hba.conf
ls: cannot access /etc/hba.conf: No such file or directory

Comment 4 Lukáš Nykrýn 2017-04-06 14:17:28 UTC

*** This bug has been marked as a duplicate of bug 1369342 ***


Note You need to log in before you can comment on or make changes to this bug.