Bug 137322 - First screen on IA64 rhr2 for rhel4 appears incomplete
First screen on IA64 rhr2 for rhel4 appears incomplete
Status: CLOSED RAWHIDE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: other (Show other bugs)
beta
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 11:23 EDT by Glen A. Foster
Modified: 2007-04-18 13:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 12:51:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guess patch to address garbage characters (551 bytes, patch)
2004-10-27 11:48 EDT, Rob Landry
no flags Details | Diff

  None (edit)
Description Glen A. Foster 2004-10-27 11:23:17 EDT
Description of problem: The very first screen of the beta RHR package
needs some clean-up.  First, I needed to run "LANG=en_US redhat-ready"
to get a "clean" display (garbage characters due to a different
language).  The text needs to be formatted better (see below) and it
appears that only 82% of the text fits in the dialog box.

Version-Release number of selected component (if applicable):
# rpm -q rhr2-rhel4
rhr2-rhel4-0.9-14.9b

How reproducible: 100%

Steps to Reproduce:
1. install rhr2-rhel4
2. run redhat-ready (see the garbage characters?)
3. run LANG=en_US redhat-ready
  
Actual results: The depiction below is accurate when viewed in
fixed-width font (e.g., in a text editor such as 'vi').

Hardware Certification Testing Suite v.2-0.9
-------------------------------------------------------------------
+============= Welcome - Red Hat Ready ==============+
|  Welcome to Red Hat Ready hardware testing. This   |
|  portion of the certification process tests the    |
|  OS to hardware interoperability. Completing this  |
|  portion is an indicator of the certification      |
|  results not the final outcome.                    |
|                                                    |
|  If you've used prior rhr releases you will        |
| notice                                             |
|  many differences. Some tests have been            |
| simplified                                         |
|  allowing faster completion while others have      |
| been                                               |
| expanded to cover more hardware. Differences are   |
|----------------------------------------------- 82%-|
|                     <  OK  >                       |
+====================================================+
Comment 1 Rob Landry 2004-10-27 11:30:05 EDT
The formatting problems are because of a dialog bug (bz #136374) and
are addressed in a newer version of that.  I'm curious about the
language and garbage characters.  What is the value of LANG that
causes the garbage characters?
Comment 2 Glen A. Foster 2004-10-27 11:32:40 EDT
# echo $LANG
en_US.UTF-8
Comment 3 Rob Landry 2004-10-27 11:44:04 EDT
The -3 of the dialog package appears to be available on
ftp:download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS
correct for arch or grab the SRPM.  Let me know if that doesn't
correct it on IPF.
Comment 4 Rob Landry 2004-10-27 11:48:41 EDT
Created attachment 105846 [details]
guess patch to address garbage characters

don't have an ia64 w/rhel4 beta on it; an i386 looks ok not great; the above
sets everything a little bright but gives the correct lines etc.  As well on
i386 like RHEL3 it looks better in X by default.
Comment 5 Glen A. Foster 2004-10-27 12:21:29 EDT
Indeed the newer dialog rpm fixes the initial-screen format issue.  It
did not, however, change the problem in bug 137324
Comment 6 Rob Landry 2004-10-27 13:19:29 EDT
correct; 137324 is a separate bug that has to be fixed
Comment 7 Rob Landry 2004-12-06 16:32:10 EST
should be doubled checked against rhr2-0.9-14.9f
Comment 8 Glen A. Foster 2004-12-06 16:38:08 EST
Did you mean rhr2-0.9-14.9f as input, or rhr2-rhel4-0.9-14.9f?

Either way, where can I get the 0.9-14.9f version to check this?
Comment 9 Glen A. Foster 2004-12-09 12:51:29 EST
Verified fix in rhr2-rhel4-0.9-14.9f

Note You need to log in before you can comment on or make changes to this bug.