Bug 1373228 - pure project admin can't view/navigate to projects
Summary: pure project admin can't view/navigate to projects
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 8.0 (Liberty)
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 10.0 (Newton)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-05 14:40 UTC by Aviv Guetta
Modified: 2016-12-14 15:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-12-14 15:56:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
Launchpad 1587951 None None None 2016-09-05 14:42:57 UTC

Description Aviv Guetta 2016-09-05 14:40:36 UTC
Description of problem:
When admin (not project admin) navigates to one of the projects, the session is thrown out to the login screen.
There is an error message in the login screen:
"You don't have permissions to access:

/dashboard/admin/

Login as different user or go back to home page

Unauthorized. Please try logging in again."

Version-Release number of selected component (if applicable):
RH-OSP8

How reproducible:
Always

Steps to Reproduce:
1.Login as admin
2. Projects -> Select Project



Actual results:
The session is thrown out to login screen.

Expected results:
The selected project should be displayed.

Additional info:
There is an upstream bug for Mitaka:
https://bugs.launchpad.net/horizon/+bug/1587951

Comment 3 Jason E. Rist 2016-10-14 23:22:48 UTC
Also is this an issue in 10?

Comment 4 Radomir Dopieralski 2016-10-18 07:19:16 UTC
The fix for this issue is included in osp10 from upstream.

It could be backported to osp9, but not to osp8 -- it requires support for domain-scoped tokens.

Comment 6 Ido Ovadia 2016-10-25 15:42:39 UTC
Verified
========
python-django-horizon-10.0.0-3.el7ost.noarch

Comment 8 errata-xmlrpc 2016-12-14 15:56:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.