Bug 1373272 - CLI always sends default command version
Summary: CLI always sends default command version
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-05 16:06 UTC by Martin Bašti
Modified: 2016-11-04 06:02 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:02:51 UTC


Attachments (Terms of Use)
console.log (4.14 KB, text/plain)
2016-09-20 12:02 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Martin Bašti 2016-09-05 16:06:24 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6279

Steps to reproduce:
{{{
[server] # ipa-server-install
add second version of some command e.g. ping/2
make the new version default
[server] # systemctl restart httpd.service
[server] # ipa -vv ping/1
}}}

Actual result:
{{{
ipa: INFO: trying https://server.example.com/ipa/json
ipa: INFO: Forwarding 'ping/2' to json server 'https://server.example.com/ipa/json'
ipa: INFO: Request: {
    "id": 0, 
    "method": "ping/2", 
    "params": [
        [], 
        {
            "version": "2.212"
        }
    ]
}
ipa: INFO: Response: {
    "error": null, 
    "id": 0, 
    "principal": "admin@EXAMPLE.COM", 
    "result": {
        "summary": "Ping version 2."
    }, 
    "version": "4.4.0.201608311132GITb30bc93"
}
---------------
Ping version 2.
---------------
}}}

Expected result:
{{{
ipa: INFO: trying https://server.example.com/ipa/json
ipa: INFO: Forwarding 'ping/1' to json server 'https://server.example.com/ipa/json'
ipa: INFO: Request: {
    "id": 0, 
    "method": "ping/1", 
    "params": [
        [], 
        {
            "version": "2.212"
        }
    ]
}
ipa: INFO: Response: {
    "error": null, 
    "id": 0, 
    "principal": "admin@EXAMPLE.COM", 
    "result": {
        "summary": "IPA server version 4.4.0.201608311055GIT5b9ca10. API version 2.212"
    }, 
    "version": "4.4.0.201608311055GIT5b9ca10"
}
------------------------------------------------------------------
IPA server version 4.4.0.201608311055GIT5b9ca10. API version 2.212
------------------------------------------------------------------
}}}

Comment 4 Abhijeet Kasurde 2016-09-20 12:02:13 UTC
Verified using IPA version ::
ipa-server-4.4.0-12.el7.x86_64

Please find the attachment as verification logs. Marking BZ as verified.

Comment 5 Abhijeet Kasurde 2016-09-20 12:02 UTC
Created attachment 1202870 [details]
console.log

Comment 7 errata-xmlrpc 2016-11-04 06:02:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.