Bug 1373344 (CVE-2016-7033) - CVE-2016-7033 JBoss bpms: stored XSS in dashbuilder
Summary: CVE-2016-7033 JBoss bpms: stored XSS in dashbuilder
Status: CLOSED ERRATA
Alias: CVE-2016-7033
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20160906,reported=2...
Keywords: Security
Depends On:
Blocks: 1373338 1412839
TreeView+ depends on / blocked
 
Reported: 2016-09-06 04:26 UTC by Jeremy Choi
Modified: 2019-06-08 21:25 UTC (History)
15 users (show)

(edit)
JBoss BRMS 6 and BPM Suite 6 are vulnerable to a stored XSS via dashbuilder. Remote, authenticated attackers that have privileges to access dashbuilder (usually admins) can store scripts in several editable fields, which are not properly sanitized before showing to other users, including other admins.
Clone Of:
(edit)
Last Closed: 2017-02-06 19:42:25 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0249 normal SHIPPED_LIVE Moderate: Red Hat JBoss BPM Suite security update 2017-02-03 01:33:32 UTC

Description Jeremy Choi 2016-09-06 04:26:50 UTC
Multiple stored XSS have been found in admin pages in jbpms 6.3.2 dashbuilder.

The vulnerable points are only accessible by admins so the risk is low, however, attackers may be able to exploit them combining with other vulnerabilities.

Comment 1 Jeremy Choi 2016-09-06 04:27:03 UTC
Acknowledgments:

Name: Jeremy Choi (Red Hat Product Security Team)

Comment 7 errata-xmlrpc 2017-02-02 20:43:19 UTC
This issue has been addressed in the following products:

  Red Hat JBoss BPM Suite 6.4.1

Via RHSA-2017:0249 https://rhn.redhat.com/errata/RHSA-2017-0249.html


Note You need to log in before you can comment on or make changes to this bug.