Bug 1373359 - ipa-certupdate fails with "CA is not configured"
Summary: ipa-certupdate fails with "CA is not configured"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florence Blanc-Renaud
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 05:48 UTC by Jan Cholasta
Modified: 2016-11-04 06:02 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:02:56 UTC


Attachments (Terms of Use)
console output (9.11 KB, text/plain)
2016-09-09 07:38 UTC, Kaleem
no flags Details
console output with verification steps (9.29 KB, text/plain)
2016-09-13 12:55 UTC, Kaleem
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Cholasta 2016-09-06 05:48:15 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6288

With a CA-less ipa server, ipa-certupdate always fails with the following error:

{{{
$ ipa-certupdate
trying https://vm-180.abc.idm.lab.eng.brq.redhat.com/ipa/session/json
Forwarding 'ca_is_enabled' to json server 'https://vm-180.abc.idm.lab.eng.brq.redhat.com/ipa/session/json'
Forwarding 'ca_find/1' to json server 'https://vm-180.abc.idm.lab.eng.brq.redhat.com/ipa/session/json'
CA is not configured
The ipa-certupdate command failed.
}}}


The code is calling ca_find but not catching the exception returned because the CA is not configured.

Comment 5 Kaleem 2016-09-09 07:35:54 UTC
Still i see same error message with ipa-server-4.4.0-10.el7.x86_64.

Please find the attachment for console output.

Comment 6 Kaleem 2016-09-09 07:38 UTC
Created attachment 1199296 [details]
console output

Comment 7 Florence Blanc-Renaud 2016-09-09 13:02:27 UTC
On master branch, commit 08b768313020c45bfa82d67cd214afabf605f4b3 introduced a regression and overwrote the fix (on ipa-4-4, commit 99b0db0ebf090c9f60078e9ca9bf2aba665635f5).

I'm making a new fix.

Comment 10 Kaleem 2016-09-13 12:53:15 UTC
Verified.

IPA Version:
============
[root@dhcp207-129 ~]# rpm -q ipa-server
ipa-server-4.4.0-11.el7.x86_64
[root@dhcp207-129 ~]# 

Please find the attached console output for verification.

Comment 11 Kaleem 2016-09-13 12:55 UTC
Created attachment 1200486 [details]
console output with verification steps

Comment 13 errata-xmlrpc 2016-11-04 06:02:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.