Bug 1373373 - Worker crashes with EINVAL errors
Summary: Worker crashes with EINVAL errors
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1374626 1374627 1374628 1425684
TreeView+ depends on / blocked
 
Reported: 2016-09-06 06:39 UTC by Aravinda VK
Modified: 2017-03-06 17:25 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1374626 1374627 1374628 1425684 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:25:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-09-06 06:39:31 UTC
Description of problem:
During Hybrid crawl if the files are unlinked then worker crashes with EINVAL error.

Steps to Reproduce:
1. Create Master Volume and generate data
2. Create Slave Volume and establish Geo-rep session and start(Starts with Hybrid Crawl for initial sync)
3. Once started wait for 2-5 seconds and delete files.

Actual results:
Worker crashes with EINVAL traceback

Expected results:
Workers should not crash

Comment 1 Worker Ant 2016-09-06 06:40:28 UTC
REVIEW: http://review.gluster.org/15404 (geo-rep: Fix ESTALE/EINVAL issue during set_{xtime,stime}) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-09-08 16:15:45 UTC
COMMIT: http://review.gluster.org/15404 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 9db2826cd8dbcc0fb58f5434c21d00ca5c15c491
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Sep 6 12:02:02 2016 +0530

    geo-rep: Fix ESTALE/EINVAL issue during set_{xtime,stime}
    
    Setfattr may get ESTALE/EINVAL if a file is being unlinked.
    To prevent worker crashing, added retry for these error messages.
    
    On second retry it will get ENOENT and that error is handled by
    ignoring.
    
    BUG: 1373373
    Change-Id: Ic660fa13208366d57c8d3d492bbef611475e45b7
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15404
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Shyamsundar 2017-03-06 17:25:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.