Bug 1373444 - unable to create group in sssd cache
Summary: unable to create group in sssd cache
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 09:56 UTC by Niranjan Mallapadi Raghavender
Modified: 2020-05-02 18:28 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-38.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:21:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4206 None None None 2020-05-02 18:28:55 UTC
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Niranjan Mallapadi Raghavender 2016-09-06 09:56:50 UTC
Description of problem:
unable to create group in sssd cache

Version-Release number of selected component (if applicable):

sssd-krb5-1.14.0-30.el7.x86_64
libsss_nss_idmap-1.14.0-27.el7.x86_64
python-sssdconfig-1.14.0-30.el7.noarch
libsss_idmap-1.14.0-30.el7.x86_64
sssd-tools-1.14.0-30.el7.x86_64
sssd-krb5-common-1.14.0-30.el7.x86_64
sssd-common-1.14.0-30.el7.x86_64
sssd-ad-1.14.0-30.el7.x86_64
sssd-dbus-1.14.0-30.el7.x86_64
sssd-common-pac-1.14.0-30.el7.x86_64
sssd-1.14.0-30.el7.x86_64
libsss_autofs-1.14.0-27.el7.x86_64
sssd-ldap-1.14.0-30.el7.x86_64
python-sss-1.14.0-30.el7.x86_64
libsss_simpleifp-1.14.0-30.el7.x86_64
sssd-client-1.14.0-30.el7.x86_64
sssd-proxy-1.14.0-30.el7.x86_64
sssd-ipa-1.14.0-30.el7.x86_64
Red Hat Enterprise Linux Workstation release 7.3 Beta (Maipo)

How reproducible:


Steps to Reproduce:
1.Configure sssd.conf as below:
[domain/LOCAL]
id_provider = local
debug_level = 0x0080


[sssd]
services = nss,pam
config_file_version = 2
domains = LOCAL

[nss]
filter_groups = root
filter_users = root


2.Add a group
 sss_groupadd -g 10000 group10000
Transaction error. Could not add group.




Actual results:

Transaction error. Could not add group.

Expected results:

Should be able to add group 

Additional info:

Comment 1 Jakub Hrozek 2016-09-06 10:18:52 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3173

Comment 3 Lukas Slebodnik 2016-09-07 18:48:03 UTC
master:
* 6be723a089a1e07a1cd19b4fa53fd142c13f0c69

Comment 4 Lukas Slebodnik 2016-09-07 18:51:19 UTC
master:
* 20c2d76d9430a1fc069531ff537df046a74c8f61
* 5210c5d3a5a83b5d08396ee23d88f6ba0994097d

Comment 6 Niranjan Mallapadi Raghavender 2016-09-12 06:37:25 UTC
Versions:
=========
sssd-testlib-0.1-3.el7.noarch
sssd-client-1.14.0-38.el7.x86_64
sssd-dbus-1.14.0-38.el7.x86_64
sssd-common-pac-1.14.0-38.el7.x86_64
python-sssdconfig-1.14.0-38.el7.noarch
sssd-krb5-common-1.14.0-38.el7.x86_64
sssd-krb5-1.14.0-38.el7.x86_64
sssd-proxy-1.14.0-38.el7.x86_64
sssd-common-1.14.0-38.el7.x86_64
sssd-ipa-1.14.0-38.el7.x86_64
sssd-1.14.0-38.el7.x86_64
sssd-debuginfo-1.14.0-30.el7.x86_64
sssd-ad-1.14.0-38.el7.x86_64
sssd-tools-1.14.0-38.el7.x86_64
sssd-ldap-1.14.0-38.el7.x86_64

1. Configure sssd.conf as below
[domain/LOCAL]
id_provider = local
debug_level = 0x0080


[sssd]
services = nss,pam
config_file_version = 2
domains = LOCAL

[nss]
filter_groups = root
filter_users = root

2. Create a user user1010
[root@client1 home]# sss_useradd -u 1010 -h /home/user1010 -s /bin/bash
user1010

3. Create a group group1010
[root@client1 home]# sss_groupadd -g 1010 group1010

4. Add user1010 member of group1010
[root@client1 home]# sss_usermod -a group1010 user1010
5. Verify the user membership
[root@client1 home]# getent passwd -s sss user1010
user1010:*:1010:1010:user1010:/home/user1010:/bin/bash

6. Create another group foo_group_1011
[root@client1 home]# sss_groupadd -g 1011 foo_group_1011

7. Make user user1010 member of foo_group_1011
[root@client1 home]# sss_usermod -a foo_group_1011 user1010

[root@client1 home]# getent passwd -s sss user1010
user1010:*:1010:1010:user1010:/home/user1010:/bin/bash
[root@client1 home]# id user1010
uid=1010(user1010) gid=1010(group1010)
groups=1010(group1010),1011(foo_group_1011

Comment 8 Niranjan Mallapadi Raghavender 2016-09-12 08:23:37 UTC
Based on Comment #6 marking it verified

Comment 10 errata-xmlrpc 2016-11-04 07:21:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.