Bug 1373485 - dns not updated after sleep and resume laptop
Summary: dns not updated after sleep and resume laptop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: 24
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1377680 1377886 1382898 1390834 (view as bug list)
Depends On: 1367772
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 11:52 UTC by Beniamino Galvani
Modified: 2016-12-08 03:53 UTC (History)
24 users (show)

Fixed In Version: dnsmasq-2.76-2.fc24 dnsmasq-2.76-2.fc23 dnsmasq-2.76-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1367772
Environment:
Last Closed: 2016-12-08 03:53:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Beniamino Galvani 2016-09-06 11:52:48 UTC
+++ This bug was initially created as a clone of Bug #1367772 +++

Description of problem:
I have NetworkManager on my laptop configured to run dnsmasq for DNS caching:

$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifcfg-rh
dns=dnsmasq

If I put my laptop to sleep, then wake it up and re-connect to the VPN, the dnsmasq process does not get updated with the new DNS information for the VPN.  I have to kill dnsmasq and let NM launch a new process in order for DNS to work.

$ ping host.inside.vpn.com
ping: host.inside.vpn.com: Name or service not known
$ pgrep -laf dnsmasq
15451 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts ...
$ sudo kill 15451
$ pgrep -laf dnsmasq
19317 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts ...
$ ping host.inside.vpn.com
PING host.inside.vpn.com (10.1.2.3) 56(84) bytes of data.
64 bytes from host.inside.vpn.com (10.1.2.3): icmp_seq=1 ttl=252 time=62.2 ms
...


Version-Release number of selected component (if applicable):
NetworkManager-1.4.0-0.5.beta1.el7.x86_64
NetworkManager-openvpn-1.0.8-1.el7.x86_64
dnsmasq-2.66-17.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. connect to VPN, work for a while, then put laptop to sleep
2. resume laptop, re-connect to VPN

Actual results:
the VPN is connected, but DNS lookups for hosts inside the VPN fail

Expected results:
DNS for VPN hosts works

Additional info:

----------

See bug 1367772 for more details.
Another report also in https://bugzilla.redhat.com/show_bug.cgi?id=1338731#c20

Comment 1 David Gibson 2016-09-19 04:18:01 UTC
I see that the fix for the corresponding RHEL bug is now VERIFIED.  Any ETA on a fixed Fedora package?

Comment 2 Jan Pazdziora 2016-09-19 06:39:09 UTC
I can't speak for regular Fedora builds. But https://copr.fedorainfracloud.org/coprs/larsks/dnsmasq/ were working fine for me as a workaround.

Comment 3 Beniamino Galvani 2016-09-20 13:41:07 UTC
*** Bug 1377680 has been marked as a duplicate of this bug. ***

Comment 4 Beniamino Galvani 2016-09-21 16:16:30 UTC
*** Bug 1377886 has been marked as a duplicate of this bug. ***

Comment 5 Thomas Haller 2016-10-08 08:33:44 UTC
*** Bug 1382898 has been marked as a duplicate of this bug. ***

Comment 6 Aleksandar Kostadinov 2016-10-10 06:25:34 UTC
+1 to the builds pointed to by Jan.

Comment 7 Beniamino Galvani 2016-10-13 09:29:48 UTC
Pavel, would it be possible to update Fedora packages with the fix?

Comment 8 Beniamino Galvani 2016-11-02 07:04:31 UTC
*** Bug 1390834 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2016-11-10 07:34:33 UTC
dnsmasq-2.76-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-139a004954

Comment 10 Fedora Update System 2016-11-10 07:35:01 UTC
dnsmasq-2.76-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c72c2c5531

Comment 11 Fedora Update System 2016-11-11 04:23:20 UTC
dnsmasq-2.76-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c72c2c5531

Comment 12 Fedora Update System 2016-11-11 05:01:53 UTC
dnsmasq-2.76-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-139a004954

Comment 13 Fedora Update System 2016-11-17 02:24:13 UTC
dnsmasq-2.76-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Tom Tromey 2016-11-19 16:26:29 UTC
I updated to dnsmasq-2.76-2.fc24 and rebooted.
The bug still persists for me -- when I close my laptop and reopen
it, the network doesn't come back up.
"sudo killall -HUP NetworkManager" does make it start working again.

I would reopen this bug but I have insufficient permissions.

Comment 15 Jan Pazdziora 2016-11-21 08:17:36 UTC
Reopening for Tom per comment 14.

Comment 16 Tom Tromey 2016-11-21 15:41:44 UTC
Thanks for reopening this.

I've noticed since then that the situation has improved.
It no longer fails reliably -- so that's quite nice.
I'd say it's something like 1 out of 10 times now (I didn't
try to really measure).
Next time it fails I will try to remember to capture the logs.

Comment 17 David Gibson 2016-11-26 01:17:08 UTC
Also seems to reproduce on Fedora 25, with dnsmasq-2.76-1.fc25.x86_64

Comment 18 Beniamino Galvani 2016-12-01 12:59:41 UTC
(In reply to David Gibson from comment #17)
> Also seems to reproduce on Fedora 25, with dnsmasq-2.76-1.fc25.x86_64

dnsmasq-2.76-1.fc25 doesn't include the fix for this bug.

Can you please try dnsmasq-2.76-2.fc25, perhaps from the updates-testing repo?

Comment 19 David Gibson 2016-12-01 23:56:12 UTC
dnsmasq-2.76-2.fc25 doesn't seem to be in updates-testing yet, so I pulled it from Koji.

So far so good.

Comment 20 Fedora Update System 2016-12-05 15:35:00 UTC
dnsmasq-2.76-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-538430598e

Comment 21 Fedora Update System 2016-12-06 02:21:10 UTC
dnsmasq-2.76-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2016-12-06 03:26:12 UTC
dnsmasq-2.76-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-538430598e

Comment 23 Fedora Update System 2016-12-08 03:53:18 UTC
dnsmasq-2.76-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.