Bug 1373540 - client-install with IPv6 address fails on link-local address (always)
Summary: client-install with IPv6 address fails on link-local address (always)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 14:39 UTC by Martin Bašti
Modified: 2016-11-04 06:03 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:03:00 UTC


Attachments (Terms of Use)
evidence (494 bytes, text/plain)
2016-09-14 13:38 UTC, Pavel Picka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Martin Bašti 2016-09-06 14:39:11 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6296

Steps to reproduce:
* ipa-client-install --ip-address 2001:db8::  # address that does not match any local interface

Traceback:
{{{
[root@vm-058-089 ~]# ipa-client-install --ip-address '2001:db8::'
WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

Traceback (most recent call last):
  File "/sbin/ipa-client-install", line 3142, in <module>
    sys.exit(main())
  File "/sbin/ipa-client-install", line 3123, in main
    rval = install(options, env, fstore, statestore)
  File "/sbin/ipa-client-install", line 2320, in install
    if not check_ip_addresses(options):
  File "/sbin/ipa-client-install", line 1807, in check_ip_addresses
    ipautil.CheckedIPAddress(ip, match_local=True)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 177, in __init__
    netmask=ifdata['netmask']
  File "/usr/lib/python2.7/site-packages/netaddr/ip/__init__.py", line 933, in __init__
    raise AddrFormatError('invalid IPNetwork %s' % addr)
netaddr.core.AddrFormatError: invalid IPNetwork fe80::21a:4aff:fe23:1595%ens3/ffff:ffff:ffff:ffff::
}}}


It looks that netaddr.IPNetwork does not allow ''%suffix'' (interface, scope)

{{{
In [3]: ifnet = netaddr.IPNetwork('fe80::21a:4aff:fe23:1595%ens3/64')
---------------------------------------------------------------------------
AddrFormatError                           Traceback (most recent call last)
<ipython-input-3-363588007859> in <module>()
----> 1 ifnet = netaddr.IPNetwork('fe80::21a:4aff:fe23:1595%ens3/64')

/usr/lib/python2.7/site-packages/netaddr/ip/__init__.pyc in __init__(self, addr, implicit_prefix, version, flags)
    931 
    932                 if value is None:
--> 933                     raise AddrFormatError('invalid IPNetwork %s' % addr)
    934 
    935         self._value = value

In [4]: ifnet = netaddr.IPNetwork('fe80::21a:4aff:fe23:1595/64')
}}}

I'm not sure if this is our bug or netaddr.IPNetwork

Comment 4 Pavel Picka 2016-09-14 13:38 UTC
Created attachment 1200825 [details]
evidence

Verified

4.4.0-11

Comment 6 errata-xmlrpc 2016-11-04 06:03:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.