Bug 137355 - inconsistancy in mime handling
inconsistancy in mime handling
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 14:35 EDT by Bill Peck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 12:29:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2004-10-27 14:35:07 EDT
Description of problem:
right click on a .doc file shows three choices for apps:
 emacs
 text editor
 oowriter

Preferences on same file, open with:
 emacs
 text editor

Version-Release number of selected component (if applicable):
nautilus-2.8.1-4

How reproducible:
everytime

Steps to Reproduce:
1. create a "rich text doc" and name it with a .doc extension
2. right click on the file will show three open options
3. prefs, open with will show two.

Seems to me two different code paths.

If you rename the file to .rtf it will show just the two choices in
both places.
Comment 1 Marco Pesenti Gritti 2005-01-12 07:40:25 EST
So, there are two problems here:

1 Nautilus add both fast/slow mime type application to the context
menu, that can be useful in case of mismatches. Doing the same for the
properties dialog would be totally confusing because you can edit the
types there. So it's useful VS possibly confusing (inconsistency).
Alex think we should pick useful here, I agree.

2 The desktop file we install for OOwriter uses text/rtf instead of
application/rtf like the freedesktop database. With that fixed oowrite
would be showed in properties too.
Comment 2 Marco Pesenti Gritti 2005-01-12 07:45:21 EST
So I'm reassigning to Open Office.

We should use application/rtf in oowriter desktop file, like the
freedesktop database. If there was a good reason to use text/rtf
please let me know and I'll get the freedesktop database fixed.
Comment 3 Caolan McNamara 2005-01-12 09:12:00 EST
caolanm->snickell: remove that text/rtf from redhat-word-processor.desktop from
redhat-menus please and replace it with application/rtf if that's not already in
the list
Comment 4 Matthias Clasen 2006-11-26 12:29:08 EST
Looking at FC6/FC7, the oowriter desktop file that we ship nowadays has
application/rtf in it. So I assume this is fixed.

Note You need to log in before you can comment on or make changes to this bug.