Bug 1373577 - unable to add local user in sssd to a group in sssd
Summary: unable to add local user in sssd to a group in sssd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Zidek
QA Contact: Steeve Goveas
URL:
Whiteboard:
: 1373579 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 15:53 UTC by Niranjan Mallapadi Raghavender
Modified: 2020-05-02 18:29 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-38.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:21:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4211 None None None 2020-05-02 18:29:07 UTC
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Niranjan Mallapadi Raghavender 2016-09-06 15:53:15 UTC
Description of problem:
unable to add local user in sssd to a group in sssd

Version-Release number of selected component (if applicable):
sssd-client-1.14.0-35.el7.x86_64
sssd-tools-1.14.0-35.el7.x86_64
sssd-krb5-1.14.0-35.el7.x86_64
python-sss-1.14.0-35.el7.x86_64
sssd-1.14.0-35.el7.x86_64
libsss_autofs-1.14.0-30.el7.x86_64
libsss_idmap-1.14.0-35.el7.x86_64
sssd-krb5-common-1.14.0-35.el7.x86_64
sssd-ldap-1.14.0-35.el7.x86_64
libsss_simpleifp-1.14.0-35.el7.x86_64
sssd-ipa-1.14.0-35.el7.x86_64
libsss_nss_idmap-1.14.0-30.el7.x86_64
sssd-debuginfo-1.14.0-30.el7.x86_64
python-sssdconfig-1.14.0-35.el7.noarch
sssd-common-pac-1.14.0-35.el7.x86_64
sssd-dbus-1.14.0-35.el7.x86_64
sssd-ad-1.14.0-35.el7.x86_64
sssd-proxy-1.14.0-35.el7.x86_64
sssd-testlib-0.1-1.el7.noarch
sssd-common-1.14.0-35.el7.x86_64


How reproducible:


Steps to Reproduce:
1. Configure sssd.conf as below
[domain/LOCAL]
id_provider = local
debug_level = 0x0080


[sssd]
services = nss,pam
config_file_version = 2
domains = LOCAL

[nss]
filter_groups = root
filter_users = root



2. 
$ sss_groupadd -g 1009 group1009
$ sss_useradd -u 1009 -h /home/user1009 -s /bin/bash user1009
$ sss_usermod -a group1009 user1009
Could not modify user - check if group names are correct

3.

Actual results:
Unable to make user member to a group in sssd 

Expected results:

Should be able to make user member of group in sssd

Additional info:

Comment 3 Michal Zidek 2016-09-07 10:58:15 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3178

Comment 4 Michal Zidek 2016-09-07 11:03:28 UTC
*** Bug 1373579 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Hrozek 2016-09-07 12:11:07 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3178

Comment 6 Lukas Slebodnik 2016-09-07 18:53:25 UTC
master:
* f2d1d90a14267c01155eab7bb95b8eb34128acc9
* cb54dbad6be907d277ce6aa39524338643e2f5a4
* 7fa4964d84f41bd80a6d971ffaeef87a7c2f19be
* 5e2142b66589e5e50cb404fc972ed5418bbaa772

Comment 7 Niranjan Mallapadi Raghavender 2016-09-12 06:34:11 UTC
Versions:
=========

sssd-testlib-0.1-3.el7.noarch
sssd-client-1.14.0-38.el7.x86_64
sssd-dbus-1.14.0-38.el7.x86_64
sssd-common-pac-1.14.0-38.el7.x86_64
python-sssdconfig-1.14.0-38.el7.noarch
sssd-krb5-common-1.14.0-38.el7.x86_64
sssd-krb5-1.14.0-38.el7.x86_64
sssd-proxy-1.14.0-38.el7.x86_64
sssd-common-1.14.0-38.el7.x86_64
sssd-ipa-1.14.0-38.el7.x86_64
sssd-1.14.0-38.el7.x86_64
sssd-debuginfo-1.14.0-30.el7.x86_64
sssd-ad-1.14.0-38.el7.x86_64
sssd-tools-1.14.0-38.el7.x86_64
sssd-ldap-1.14.0-38.el7.x86_64

1. Configure sssd.conf as below
[domain/LOCAL]
id_provider = local
debug_level = 0x0080


[sssd]
services = nss,pam
config_file_version = 2
domains = LOCAL

[nss]
filter_groups = root
filter_users = root

2. Create a user user1010
[root@client1 home]# sss_useradd -u 1010 -h /home/user1010 -s /bin/bash user1010

3. Create a group group1010
[root@client1 home]# sss_groupadd -g 1010 group1010

4. Add user1010 member of group1010
[root@client1 home]# sss_usermod -a group1010 user1010
5. Verify the user membership
[root@client1 home]# getent passwd -s sss user1010
user1010:*:1010:1010:user1010:/home/user1010:/bin/bash

6. Create another group foo_group_1011
[root@client1 home]# sss_groupadd -g 1011 foo_group_1011

7. Make user user1010 member of foo_group_1011
[root@client1 home]# sss_usermod -a foo_group_1011 user1010

[root@client1 home]# getent passwd -s sss user1010
user1010:*:1010:1010:user1010:/home/user1010:/bin/bash
[root@client1 home]# id user1010
uid=1010(user1010) gid=1010(group1010) groups=1010(group1010),1011(foo_group_1011

Comment 9 Niranjan Mallapadi Raghavender 2016-09-12 08:21:59 UTC
Based on Comment #7 marking it verified

Comment 11 errata-xmlrpc 2016-11-04 07:21:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.