Bug 1373598 - OSP-9/10 upgrades fails on upgrade because of mariadb-libs package conflict.
Summary: OSP-9/10 upgrades fails on upgrade because of mariadb-libs package conflict.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: mariadb-galera
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Michael Bayer
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks: 1337794 1376902 1376903 1376904 1376905 1376906
TreeView+ depends on / blocked
 
Reported: 2016-09-06 16:51 UTC by Sofer Athlan-Guyot
Modified: 2018-01-16 12:12 UTC (History)
15 users (show)

Fixed In Version: mariadb-galera-5.5.42-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Previously, both the 'mariadb-server' and 'mariadb-galera-server' packages shipped the client-facing libraries: 'dialog.so' and 'mysql_clear_password.so'. As a result, the 'mariadb-galera-server' package would fail to install because of package conflicts. With this update, the 'dialog.so' and 'mysql_clear_password.so' libraries have been moved from 'mariadb-galera-server' to 'mariadb-libs'. As a result, the 'mariadb-galera-server' package installs successfully.
Clone Of:
: 1376902 1376903 1376904 1376905 1376906 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:57:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Sofer Athlan-Guyot 2016-09-06 16:51:34 UTC
Description of problem:  On a OSP-9 platform using rhel 7.2, running the upgrade -y fails.

18:15:37 + yum -y -q update

Total 30 MB/s |  80 MB  00:00:02     
Running transaction check
Running transaction test


Transaction check error:
  file /usr/lib64/mysql/plugin/dialog.so from install of mariadb-libs-1:5.5.50-2.el7.x86_64 conflicts with file from package mariadb-galera-server-1:5.5.42-2.el7ost.x86_64
  file /usr/lib64/mysql/plugin/mysql_clear_password.so from install of mariadb-libs-1:5.5.50-2.el7.x86_64 conflicts with file from package mariadb-galera-server-1:5.5.42-2.el7ost.x86_64


The package are 7.2 and the enabled repository are 7.3 as required by https://bugzilla.redhat.com/show_bug.cgi?id=1373140

[root@overcloud-controller-0 ~]# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
rhelosp-10.0-brew RHOS-10.0 856
rhelosp-10.0-ceph-2.0-mon Ceph 2.0 MON 41
rhelosp-10.0-ceph-2.0-osd Ceph 2.0 OSD 28
rhelosp-10.0-ceph-2.0-tools Ceph 2.0 Tools 33
rhelosp-10.0-fast-datapth Fast Datapath packages 9
rhelosp-rhel-7-common/x86_64 RHEL 7 Common 209
rhelosp-rhel-7.3-extras/x86_64 Red Hat Enterprise Linux 7Server - x86_64 - Extras 85
rhelosp-rhel-7.3-server/x86_64 Red Hat Enterprise Linux 7Server - x86_64 - Server 4,778
rhos-release RHOS Release 126
rhos-release-extras/7Server RHOS Release Extras 2
repolist: 6,167

How reproducible: Only once, yet.


Steps to Reproduce:
1. install mariadb* from 7.2
2. upgrade repo to 7.3
3. upgrade packages.

Actual results: the above failure

Expected results: successful mariadb upgrade

Comment 2 Sofer Athlan-Guyot 2016-09-06 17:06:17 UTC
Some more packages information:

Repository rhelosp-rhel-7-common is listed more than once in the configuration
mariadb-libs.x86_64                1:5.5.50-1.el7_2      @koji-override-0/7.2 
  
[root@overcloud-controller-0 ~]# yum list installed | grep mariadb-galera 
Repository rhelosp-rhel-7-common is listed more than once in the configuration
mariadb-galera-common.x86_64       1:5.5.42-2.el7ost     @rhos-9.0-signed       
mariadb-galera-server.x86_64       1:5.5.42-2.el7ost     @rhos-9.0-signed

Comment 3 Michael Bayer 2016-09-06 17:07:45 UTC
first thing I notice in mariadb-libs:

* Mon May 09 2016 Honza Horak <hhorak@redhat.com> - 1:5.5.47-4
- dialog.so and mysql_clear_password.so should be in mariadb-libs package
  Resolves: #1138843

Comment 5 Mike Burns 2016-09-06 18:19:24 UTC
What I'm not understanding here is how the same -galera package works with the 7.2.z build, but not the 7.3 build.  

Before:  

mariadb-libs.x86_64                1:5.5.50-1.el7_2
mariadb-galera-server.x86_64       1:5.5.42-2.el7ost

After
mariadb-libs.x86_64                1:5.5.50-2.el7
mariadb-galera-server.x86_64       1:5.5.42-2.el7ost

Comment 6 Mike Burns 2016-09-06 18:28:12 UTC
Further updates:

I ran a couple tests locally without fully installing OpenStack.

With this installed:  

mariadb-libs.x86_64                1:5.5.50-1.el7_2

I could successfully install mariadb-galera-server.  I could not update to 5.5.50-2.el7.

With 5.5.50-2.el7 installed, I could not install mariadb-galera-server.

This confirms that it would not impact OSP 9 today, but when RHEL 7.3 ships, we would have a problem.

Comment 8 Sofer Athlan-Guyot 2016-09-07 09:42:00 UTC
As a workaround, using 

     yum versionlock 'mariadb*'

let the upgrade proceed.

Comment 9 Sofer Athlan-Guyot 2016-09-07 09:43:19 UTC
The above workaround should not be used in prod env as having old mariadb* with new system library might cause unexpected error.

Comment 19 Marian Krcmarik 2016-10-19 20:36:06 UTC
Verified that upgrading mariadb from 7.2.z to 7.3 did not cause described problem.

Comment 22 errata-xmlrpc 2016-12-14 15:57:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.