Bug 1373614 - pcs bind address option
Summary: pcs bind address option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 18:04 UTC by Alexey Kurnosov
Modified: 2018-01-22 10:40 UTC (History)
8 users (show)

Fixed In Version: pcs-0.9.158-3.el7
Doc Type: Release Note
Doc Text:
Ability to configure pcsd bind addresses You can now configure `pcsd` bind addresses in the `/etc/sysconfig/pcsd` file. In previous releases, `pcsd` could bind to all interfaces, a situation that is not suitable for some users. By default, `pcsd` binds to all interfaces.
Clone Of:
Environment:
Last Closed: 2017-08-01 18:22:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed fix (3.48 KB, patch)
2017-05-22 10:48 UTC, Tomas Jelinek
no flags Details | Diff
fix exit code (707 bytes, patch)
2017-05-29 15:36 UTC, Tomas Jelinek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1958 normal SHIPPED_LIVE pcs bug fix and enhancement update 2017-08-01 18:09:47 UTC

Description Alexey Kurnosov 2016-09-06 18:04:30 UTC
Description of problem:
We need a capability to bind pcsd on a specific address.

Version-Release number of selected component (if applicable):
pcs-0.9.143-15


Additional info:
The issue is resolved:
https://github.com/ClusterLabs/pcs/issues/77
https://github.com/ClusterLabs/pcs/commit/81a952d8a6db4bba0408fc4d874e4e3c90a68286
Please, do a package update/backport.

Comment 2 Tomas Jelinek 2016-09-08 10:56:04 UTC
This is already included in the package due to rebase. See https://github.com/ClusterLabs/pcs/issues/77 for details.

Comment 7 Tomas Jelinek 2017-05-22 10:48:06 UTC
Created attachment 1280991 [details]
proposed fix

Comment 8 Tomas Jelinek 2017-05-26 11:06:28 UTC
After fix:

[root@rh73-node1:~]# rpm -q pcs
pcs-0.9.158-2.el7.x86_64

[root@rh73-node1:~]# grep PCSD_BIND_ADDR /etc/sysconfig/pcsd
PCSD_BIND_ADDR='10.15.105.32'
[root@rh73-node1:~]# systemctl -l restart pcsd
[root@rh73-node1:~]# cat /var/log/pcsd/pcsd.log
I, [2017-05-26T13:01:34.096139 #9347]  INFO -- : Running: /usr/bin/openssl x509 -modulus -noout
I, [2017-05-26T13:01:34.096205 #9347]  INFO -- : CIB USER: hacluster, groups: 
I, [2017-05-26T13:01:34.108314 #9347]  INFO -- : Return Value: 0
I, [2017-05-26T13:01:34.108399 #9347]  INFO -- : Running: /usr/bin/openssl rsa -modulus -noout
I, [2017-05-26T13:01:34.108425 #9347]  INFO -- : CIB USER: hacluster, groups: 
I, [2017-05-26T13:01:34.115442 #9347]  INFO -- : Return Value: 0
I, [2017-05-26T13:01:34.170936 #9347]  INFO -- : Listening on 10.15.105.32 port 2224
[2017-05-26 13:01:34] INFO  WEBrick 1.3.1
[2017-05-26 13:01:34] INFO  ruby 2.0.0 (2015-12-16) [x86_64-linux]
[2017-05-26 13:01:34] WARN  TCPServer Error: Cannot assign requested address - bind(2)
E, [2017-05-26T13:01:34.171798 #9347] ERROR -- : Unable to bind to specified address(es), exiting
E, [2017-05-26T13:01:34.171825 #9347] ERROR -- : Cannot assign requested address - bind(2)

[root@rh73-node1:~]# grep PCSD_BIND_ADDR /etc/sysconfig/pcsd
PCSD_BIND_ADDR='192.168.122.131,::'
[root@rh73-node1:~]# systemctl -l restart pcsd
[root@rh73-node1:~]# cat /var/log/pcsd/pcsd.log
I, [2017-05-26T13:05:09.172769 #9796]  INFO -- : Running: /usr/bin/openssl x509 -modulus -noout
I, [2017-05-26T13:05:09.172846 #9796]  INFO -- : CIB USER: hacluster, groups: 
I, [2017-05-26T13:05:09.184929 #9796]  INFO -- : Return Value: 0
I, [2017-05-26T13:05:09.185010 #9796]  INFO -- : Running: /usr/bin/openssl rsa -modulus -noout
I, [2017-05-26T13:05:09.185037 #9796]  INFO -- : CIB USER: hacluster, groups: 
I, [2017-05-26T13:05:09.192344 #9796]  INFO -- : Return Value: 0
I, [2017-05-26T13:05:09.251670 #9796]  INFO -- : Listening on 192.168.122.131 port 2224
[2017-05-26 13:05:09] INFO  WEBrick 1.3.1
I, [2017-05-26T13:05:09.252130 #9796]  INFO -- : Running: /usr/sbin/corosync-cmapctl totem.cluster_name
[2017-05-26 13:05:09] INFO  ruby 2.0.0 (2015-12-16) [x86_64-linux]
[2017-05-26 13:05:09] INFO  
Certificate:
{...snip...}
I, [2017-05-26T13:05:09.252971 #9796]  INFO -- : CIB USER: hacluster, groups: 
I, [2017-05-26T13:05:09.252809 #9796]  INFO -- : Adding listener on :: port 2224
[2017-05-26 13:05:09] WARN  TCPServer Error: Address already in use - bind(2)
E, [2017-05-26T13:05:09.254099 #9796] ERROR -- : Unable to bind to specified address(es), exiting
E, [2017-05-26T13:05:09.254133 #9796] ERROR -- : Address already in use - bind(2)

Comment 11 Tomas Jelinek 2017-05-29 15:36:01 UTC
Created attachment 1283294 [details]
fix exit code

Comment 12 Ivan Devat 2017-05-31 12:41:48 UTC
After Fix:

[vm-rhel72-1 ~] $ rpm -q pcs
pcs-0.9.158-3.el7.x86_64

[vm-rhel72-1 ~] $ grep PCSD_BIND_ADDR /etc/sysconfig/pcsd
PCSD_BIND_ADDR='10.15.105.32'
[vm-rhel72-1 ~] $ systemctl -l restart pcsd
Job for pcsd.service failed because the control process exited with error code. See "systemctl status pcsd.service" and "journalctl -xe" for details

Comment 17 errata-xmlrpc 2017-08-01 18:22:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1958

Comment 18 dnahrblock 2018-01-22 10:40:27 UTC
McDonald's Customer Satisfaction Survey - www.mcdvoice.com
McDonald's Customer Satisfaction Survey, powered by Service Management Group, at www.mcdvoice.com is meant to measure customers' approval or disapproval with the company's products and customer service.
http://www.mcd-voice.xyz


Note You need to log in before you can comment on or make changes to this bug.