Bug 137367 - Error creating link when user has no rights in directory
Summary: Error creating link when user has no rights in directory
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL: http://www.deventercity.nl
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-27 20:06 UTC by Mathijs Tieleman
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-18 18:28:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of 'right mouse-button on Download folder' (27.47 KB, image/png)
2007-11-18 18:25 UTC, Peter van Egdom
no flags Details
Screenshot of 'dragging Download folder with middle mouse-button' (20.50 KB, image/png)
2007-11-18 18:27 UTC, Peter van Egdom
no flags Details

Description Mathijs Tieleman 2004-10-27 20:06:20 UTC
If there is a structure: /home/download

User "Internet" has no rights creating anything below /home, but has
all rights within the download directory.

Now, I (logged on as "Internet" user) like to see a Link to my
download directory at my Desktop.

I start Nautilus, navigate to /home, right click the download folder.
Click the "Make Link" option and....nothing happens. 

What I would like to see is a popup, asking me where to store the Link.

Success

Mathijs.

Comment 1 Alexander Larsson 2005-01-11 14:29:22 UTC
Are you sure it didn't create a link called "link to download" in /home?

Comment 2 Matthew Miller 2007-04-06 15:18:01 UTC
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.


Comment 3 Peter van Egdom 2007-11-18 18:22:46 UTC
Thanks for the bug report. I tried reproducing this on my machine (Fedora
release 8, with package "nautilus-2.20.0-6.fc8"), but it appears that this is
not a bug, but a feature.

It there exists a directory "/home/download" and user/group "root:root" is the
owner of the "/home" directory :

  [root@pavilion /]# ll -d /home/
  drwxr-xr-x 8 root root 4096 2007-11-18 18:49 /home/

then my user-account has no rights to write in the "/home" directory directly.

When I (from the GNOME desktop) right-click on "/home/download" (see attached
file "screenshot-1.png") the option 'Make Link' stays greyed-out, because
Nautilus has no rights (... out of the box) to make a link of the directory
"/home/download" inside the "/home" directory.

But when I change the rights of the "/home" directory to my user-account then it
_is_ possible to select the option 'Make Link'.

To let Nautilus do what you want it to do in this case, you can use the middle
mouse-button (... or the scroll-wheel) and drag the "Download" folder to your
GNOME desktop and select 'Link Here' to create a link inside
"/home/Internet/Desktop" (see attached file "screenshot-2.png").

Comment 4 Peter van Egdom 2007-11-18 18:25:53 UTC
Created attachment 263051 [details]
Screenshot of 'right mouse-button on Download folder'

Comment 5 Peter van Egdom 2007-11-18 18:27:11 UTC
Created attachment 263061 [details]
Screenshot of 'dragging Download folder with middle mouse-button'


Note You need to log in before you can comment on or make changes to this bug.