Bug 1373853 - OSP-9/10 upgrades upgrade-non-controller.sh doesn't fail if the triggered script fails.
Summary: OSP-9/10 upgrades upgrade-non-controller.sh doesn't fail if the triggered scr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-09-07 09:33 UTC by Sofer Athlan-Guyot
Modified: 2017-01-11 05:09 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: Bug Fix
Doc Text:
The Compute role and Object Storage role upgrade scripts for upgrading from the Red Hat OpenStack Platform 9 (mitaka) to Red Hat OpenStack Platform 10 (newton) did not exit on error as expected. As a result, the 'upgrade-non-controller.sh' script returned code 0 (success) even when the upgrade failed. With this update, the Compute role and the Object Storage role upgrade scripts now exit on error during the upgrade process and the 'upgrade-non-controller.sh' returns a non-zero (failure) value if the upgrade fails.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:57:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 366623 None None None 2016-09-07 09:34:58 UTC
Launchpad 1620973 None None None 2016-09-07 09:33:42 UTC

Description Sofer Athlan-Guyot 2016-09-07 09:33:43 UTC
Description of problem:

Running:

  upgrade-non-controller.sh --upgrade overcloud-objectstorage-0

I've got an error but the exit code of the above command was 0 instead of 1. This make it hard to detect error in ci.


Version-Release number of selected component (if applicable): latest


How reproducible: always


Steps to Reproduce:
1. get osp9
2. upgrade undercloud, trigger overcloud upgrade init
3. run the object storage upgrade

Actual results: exit code 0 while the script /root/tripleo_upgrade_node.sh failed


Expected results: exit code 1 of upgrade-non-controller.sh when /root/tripleo_upgrade_node.sh fails

Comment 2 Sofer Athlan-Guyot 2016-09-07 09:34:58 UTC
Adding associated review.

Comment 4 Omri Hochman 2016-11-07 21:40:43 UTC
unable to reproduce : openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 15:57:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.