Bug 1373922 - Need man page entry for "--no-content" under "THE CAT-MANIFEST COMMAND" section "OPTIONS"
Summary: Need man page entry for "--no-content" under "THE CAT-MANIFEST COMMAND" secti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-07 12:37 UTC by Rehana
Modified: 2017-08-01 19:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1489 None None None 2016-09-14 18:24:14 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Rehana 2016-09-07 12:37:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):
subscription management server: 2.0.16-1
subscription management rules: 5.20
subscription-manager: 1.17.13-1.el7
python-rhsm: 1.17.7-1.el7


How reproducible:


Steps to Reproduce:
1.man rct 
2.look for cat-manifest option
3.

Actual results:
observed that the new option '--no-content' was mentioned only under the "COMMANDS" section for cat-manifest 

cat-manifest   Prints  the  information that is contained in the subscription service manifest. The manifest is an archive of JSON files which con        tain all of the subscription information for subscriptions allocated to the on-premise service. The --no-content option can be  used to reduce the detail shown in the output.
 
and NOT present under the "THE CAT-MANIFEST COMMAND" section "OPTIONS" 

Expected results:
There should be an entry for '--no-content option' under the "THE CAT-MANIFEST COMMAND" section "OPTIONS" 


Additional info:

Comment 3 Rehana 2017-04-03 04:41:48 UTC
Retested on ;
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

Observed a man page entry for "--no-content" option under the cat-manifest command section 

THE CAT-MANIFEST COMMAND
       A subscription management service is allocated a specific bloc of subscriptions that are available to an account. This list of subscriptions is the manifest for the service. The cat-manifest command
       reads and prints the details of the manifest, such as the creation date, the system UUID and name, available products, and subscription details.

       There are multiple JSON files in the archive, identifying different aspects of the subscription service and subscription configuration, such as the general manifest properties, subscription informa‐
       tion, content and repository information, and product information.

  
OPTIONS
       --no-content
              Excludes all of the Content Sets sections, which significantly reduces the information printed to stdout.

Marking as verified!!

Comment 4 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.