Bug 1374 - RPM
RPM
Status: CLOSED WORKSFORME
Product: Red Hat Powertools
Classification: Retired
Component: autorpm (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-28 21:00 EST by theposts
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-08 22:09:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description theposts 1999-02-28 21:00:55 EST
This is not per se a bug, but I can't find any other avenue
to report this problem. I bought the Power Tools CD and
can't use it because everything is an RPM file. I'm running
Slackware Linux and have no desire to switch to Redhat. RPM
does NOT run on my system--I get a 'segmentation fault'.
Your CD is totally useless unless the programs can be
installed on any Linux distribution. If you're going to
sell it, don't you think you should supply users with the
tools they need to install the software without insisting
that they have Redhat Linux? I applaud your effort to put
Microsoft out of business, but not if you intend to replace
them! Since I spent quite a few bucks to buy your CD, I
think the least you can do is to allow me to use it without
spending even more money. How can I get RPM to run on my
system??????

Thanks for your help and (hopefully) a prompt reply....
    Jeff Post -- theposts@soca.com
Comment 1 Jeff Johnson 1999-03-08 22:09:59 EST
You will need to install rpm if you wish to install rpms from
the PowerTools on a Slackware system. To do that, make sure you
have zlib, db-1.85, and bzip2 installed, then rebuild rpm from
the rpm-2.5.7 tarball found at rpm.redhat.com.

Many of the rpm's on the PowerTools CD expect glibc2. If slackware
is not using glibc2, then you will need to rebuild most of the
rpms using rpm --rebuild.

Note You need to log in before you can comment on or make changes to this bug.