Bug 1374066 - metadata_percent and origin status fields are missing in rhel7.3
Summary: metadata_percent and origin status fields are missing in rhel7.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-07 20:45 UTC by Corey Marthaler
Modified: 2016-11-04 04:18 UTC (History)
7 users (show)

Fixed In Version: lvm2-2.02.165-3.el7
Doc Type: No Doc Update
Doc Text:
In between release bug fix
Clone Of:
Environment:
Last Closed: 2016-11-04 04:18:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Corey Marthaler 2016-09-07 20:45:48 UTC
Description of problem:
Feel free to close this if this is now expected behavior in rhel7.3.

# RHEL7.2
3.10.0-327.28.3.el7.x86_64
lvm2-2.02.130-5.el7_2.5    BUILT: Tue Jun 14 03:30:35 CDT 2016


[root@host-128 ~]# lvcreate -L 4G -n origin test
  Logical volume "origin" created.
[root@host-128 ~]# lvcreate -L 4G -n pool test
  Logical volume "pool" created.
[root@host-128 ~]# lvcreate -L 12M -n pool_meta test
  Logical volume "pool_meta" created.
[root@host-128 ~]# lvconvert --yes --type cache-pool --cachepolicy smq --cachemode writethrough -c 32 --poolmetadata test/pool_meta test/pool
  WARNING: Converting logical volume test/pool and test/pool_meta to pool's data and metadata volumes.
  THIS WILL DESTROY CONTENT OF LOGICAL VOLUME (filesystem etc.)
  Converted test/pool to cache pool.
[root@host-128 ~]# lvconvert --yes --type cache --cachepool test/pool test/origin
  Logical volume test/origin is now cached.
[root@host-128 ~]# lvs -a -o +devices
  LV              VG   Attr       LSize   Pool   Origin         Data% Meta% Cpy%Sync Devices
  [lvol0_pmspare] test ewi-------  12.00m                                            /dev/sda1(2051)
  origin          test Cwi-a-C---   4.00g [pool] [origin_corig] 0.00  8.66  100.00   origin_corig(0)
  [origin_corig]  test owi-aoC---   4.00g                                            /dev/sda1(0)
  [pool]          test Cwi---C---   4.00g                       0.00  8.66  100.00   pool_cdata(0)
  [pool_cdata]    test Cwi-ao----   4.00g                                            /dev/sda1(1024)
  [pool_cmeta]    test ewi-ao----  12.00m                                            /dev/sda1(2048)

[root@host-128 ~]#  lvs -o origin test/origin
  Origin        
  [origin_corig]

[root@host-128 ~]# lvs -o metadata_percent test/origin
  Meta% 
  8.66  




# RHEL7.3
3.10.0-501.el7.x86_64
lvm2-2.02.165-1.el7    BUILT: Wed Sep  7 11:04:22 CDT 2016

[root@host-118 ~]# lvcreate -L 4G -n origin test
  Logical volume "origin" created.
[root@host-118 ~]# lvcreate -L 4G -n pool test
  Logical volume "pool" created.
[root@host-118 ~]# lvcreate -L 12M -n pool_meta test
  Logical volume "pool_meta" created.
[root@host-118 ~]# lvconvert --yes --type cache-pool --cachepolicy smq --cachemode writethrough -c 32 --poolmetadata test/pool_meta test/pool
  WARNING: Converting logical volume test/pool and test/pool_meta to cache pool's data and metadata volumes with metadata wiping.
  THIS WILL DESTROY CONTENT OF LOGICAL VOLUME (filesystem etc.)
  Converted test/pool to cache pool.
[root@host-118 ~]# lvconvert --yes --type cache --cachepool test/pool test/origin
  Logical volume test/origin is now cached.
[root@host-118 ~]# lvs -a -o +devices
  LV              VG   Attr       LSize   Pool   Origin Data% Meta% Cpy%Sync Devices
  [lvol0_pmspare] test ewi-------  12.00m                                    /dev/sda1(2051)
  origin          test Cwi-a-C---   4.00g [pool]        0.00        100.00   origin_corig(0)
  [origin_corig]  test owi-aoC---   4.00g                                    /dev/sda1(0)
  [pool]          test Cwi---C---   4.00g                                    pool_cdata(0)
  [pool_cdata]    test Cwi-ao----   4.00g                                    /dev/sda1(1024)
  [pool_cmeta]    test ewi-ao----  12.00m                                    /dev/sda1(2048)

[root@host-118 ~]# lvs -o origin test/origin
  Origin


[root@host-118 ~]# lvs -o metadata_percent test/origin
  Meta%

Comment 2 Zdenek Kabelac 2016-09-09 13:18:01 UTC
Yep - clear lvs output regression.

Hotfixed with following patch:

https://www.redhat.com/archives/lvm-devel/2016-September/msg00019.html

Although we clearly want to resolve this whole code with cleaner rewrite in a future.

Comment 4 Corey Marthaler 2016-09-19 18:59:46 UTC
It appears that metadata_percent is now present in the latest rpms, however the origin is still missing. Is origin coming in the next build, or should this be verified for "metadata_percent" *only* and an additional bug be filed for missing "origin"status.


[root@host-117 ~]# lvs -a -o +devices
  LV              VG    Attr       LSize  Pool   Origin Data% Meta% Cpy%Sync Devices
  [lvol0_pmspare] test  ewi------- 12.00m                                    /dev/sda1(2051)
  origin          test  Cwi-a-C---  4.00g [pool]        0.00  8.66  0.00     origin_corig(0)
  [origin_corig]  test  owi-aoC---  4.00g                                    /dev/sda1(0)
  [pool]          test  Cwi---C---  4.00g               0.00  8.66  0.00     pool_cdata(0)
  [pool_cdata]    test  Cwi-ao----  4.00g                                    /dev/sda1(1024)
  [pool_cmeta]    test  ewi-ao---- 12.00m                                    /dev/sda1(2048)


# Still missing
[root@host-117 ~]# lvs -o origin test/origin
  Origin
        
[root@host-117 ~]# lvs -o metadata_percent test/origin
  Meta% 
  8.66  


3.10.0-501.el7.x86_64
lvm2-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
lvm2-libs-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
lvm2-cluster-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-libs-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-event-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-event-libs-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016

Comment 5 Zdenek Kabelac 2016-09-20 13:02:58 UTC
Origin fix was missing and previous patchset repaired only metadata%.
Reporting of origin has been restored by this upstream patch:

https://www.redhat.com/archives/lvm-devel/2016-September/msg00065.html

Comment 7 Corey Marthaler 2016-09-21 19:59:10 UTC
Fix verified in the latest rpms.


3.10.0-501.el7.x86_64
lvm2-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
lvm2-libs-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
lvm2-cluster-2.02.165-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-libs-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-event-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-event-libs-1.02.134-3.el7    BUILT: Wed Sep 21 08:26:18 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016



[root@host-119 ~]# lvs -a -o +devices
  LV              VG            Attr       LSize   Pool   Origin         Data%  Meta%  Move Log Cpy%Sync Convert Devices        
  root            rhel_host-119 -wi-ao----   6.20g                                                               /dev/vda2(205) 
  swap            rhel_host-119 -wi-ao---- 820.00m                                                               /dev/vda2(0)   
  [lvol0_pmspare] test          ewi-------  12.00m                                                               /dev/sda1(2051)
  origin          test          Cwi-a-C---   4.00g [pool] [origin_corig] 0.00   8.66            0.00             origin_corig(0)
  [origin_corig]  test          owi-aoC---   4.00g                                                               /dev/sda1(0)   
  [pool]          test          Cwi---C---   4.00g                       0.00   8.66            0.00             pool_cdata(0)  
  [pool_cdata]    test          Cwi-ao----   4.00g                                                               /dev/sda1(1024)
  [pool_cmeta]    test          ewi-ao----  12.00m                                                               /dev/sda1(2048)

[root@host-119 ~]# lvs -o origin test/origin
  Origin        
  [origin_corig]
[root@host-119 ~]# lvs -o metadata_percent test/origin
  Meta% 
  8.66

Comment 9 errata-xmlrpc 2016-11-04 04:18:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.