Bug 1374087 - TravisCI down for .org site?
Summary: TravisCI down for .org site?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: website
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-07 23:11 UTC by Amye Scavarda
Modified: 2016-09-08 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-08 02:15:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amye Scavarda 2016-09-07 23:11:24 UTC
Reporting this as a possible bug, commits are merging but not showing up on the .org website, and TravisCI doesn't appear to be checking against PRs.

Comment 1 Amye Scavarda 2016-09-07 23:12:20 UTC
Assigning to misc for triage.

Comment 2 Nigel Babu 2016-09-08 02:15:58 UTC
Travis CI broke because we revoked permissions from all external apps. I've granted Travis an exception so it works.

The build broke with this pull request: https://github.com/gluster/glusterweb/pull/104/

It should be fixed with this one: https://github.com/gluster/glusterweb/pull/106

Comment 3 Michael S. 2016-09-08 10:05:56 UTC
So another error during the build is that someone did removed branches from git, and this broke the cron job:

$ git pull --rebase 
error: unable to resolve reference refs/remotes/origin/events/2016/osbconf: Not a directory
From https://github.com/gluster/glusterweb
 ! [new branch]      events/2016/osbconf -> origin/events/2016/osbconf  (unable to update local ref)
error: some local refs could not be updated; try running
 'git remote prune origin' to remove any old, conflicting branches

I guess I have now to fix the cron job to take this case of figure in account.

Comment 4 Michael S. 2016-09-08 10:45:25 UTC
For people who want to follow: https://github.com/OSAS/ansible-role-middleman_builder/pull/9


Note You need to log in before you can comment on or make changes to this bug.