Bug 1374093 - glusterfs: create a directory with 0464 mode return EIO error
Summary: glusterfs: create a directory with 0464 mode return EIO error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1374568 1374639 1374640 1374641
TreeView+ depends on / blocked
 
Reported: 2016-09-07 23:57 UTC by Pranith Kumar K
Modified: 2017-03-06 17:25 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1373828
: 1374639 1374640 1374641 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:25:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Pranith Kumar K 2016-09-08 00:27:01 UTC
Steps to Reproduce:
On Server:
1. mkdir /bricks/gluster/data
2. gluster volume create gluster4test ${SERVER}:/bricks/gluster/data force
3. gluster volume start gluster4test
On Client:
1. mount -t glusterfs ${FSOPTS} ${SERVER}:/gluster4test /gluster/mnt
2. cd /gluster/mnt; git clone git://git.code.sf.net/p/ntfs-3g/pjd-fstest
3. cd pjd-fstest; prove -rf tests/utime/00.t

Or manually:
[root@hp-xw6600-02 pjd-fstest]# less /var/log/glusterfs/gluster-mnt.log
[root@hp-xw6600-02 pjd-fstest]# cd ..
[root@hp-xw6600-02 mnt]# ./pjd-fstest/fstest mkdir dir 0777
0
[root@hp-xw6600-02 mnt]# ./pjd-fstest/fstest chown dir 65534 65534
0
[root@hp-xw6600-02 mnt]# ./pjd-fstest/fstest -u 65534 -g 65534 create dir/file 0464
changing groups to 65534
changing uid to 65534
0
[root@hp-xw6600-02 mnt]# ./pjd-fstest/fstest -u 65534 -g 65534 mkdir dir/dir 0464
changing groups to 65534
changing uid to 65534
mkdir returned -1
EIO

Comment 2 Pranith Kumar K 2016-09-08 00:27:46 UTC
remote:   http://review.gluster.org/15420 cluster/dht: Don't merge invalid stbuf
remote:   http://review.gluster.org/15421 system/posix-acl: Unwind with NULL xdata on error

Comment 3 Worker Ant 2016-09-09 23:22:34 UTC
REVIEW: http://review.gluster.org/15421 (system/posix-acl: Unwind with NULL xdata on error) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Worker Ant 2016-09-13 08:05:08 UTC
COMMIT: http://review.gluster.org/15421 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit c9271ff14d3efa8279cf67907548b3f43970d4fb
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Sep 8 05:43:20 2016 +0530

    system/posix-acl: Unwind with NULL xdata on error
    
    In posix-acl when there are errors xdata that comes as part of input is used to
    unwind which can be used as response xdata which may lead to problems as the
    keys in the input will match with keys in the output but the values the
    response xdata may expect can be completely different.
    
    For example, we see that dht sends DHT_IATT_IN_XDATA_KEY in setxattr
    which will be unwound with the same key in the xdata-response which
    dht thinks is valid response and fills stbuf with invalid values
    leading to EIO
    
    BUG: 1374093
    Change-Id: I6b77a1fa1ee99cb62e181e1db2e6fea73f6eaaa3
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/15421
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 5 Shyamsundar 2017-03-06 17:25:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.