Bug 137412 - [qt] cannot handle Key event and IM event together correctly
[qt] cannot handle Key event and IM event together correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
Depends On:
Blocks: IIIMF 137149
  Show dependency treegraph
 
Reported: 2004-10-28 07:27 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 10:43:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2004-10-28 07:27:22 EDT
Description of problem:
Qt cannot handle Key event and IM event together correctly. The order
will swap around when they posted together.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. login into KDE using ko_KR.UTF-8
2. kedit
3. shift-space
4. rkeksk<space>

  
Actual results:
output will be rkek<space>sk in hangul

Expected results:
output will be rkeksk<space> in hangul

Additional info:
Comment 1 Leon Ho 2004-11-01 06:40:22 EST
Look like it is a problem on over-the-spot method in current im module. I am
contacting the developer now to try to get some fixes on qt immodule.

However we should move back to on-the-spot now as it has improved since we
visited a while ago. The method handles this situation correctly, plus
on-the-spot is using application to render the preedit area. I have tested with
input methods they are have better behavior.

Than, can we s/Over The Spot/On The Spot/ in /usr/lib/qt-3.3/etc/settings/qtrc
in redhat-artwork and qt package for RHEL4?

Thanks.
Comment 2 Ngo Than 2004-11-02 05:34:56 EST
sure, i will do it in next rebuild. please let me know if the bug in
qt immodule is fixed. thanks
Comment 3 Ngo Than 2004-11-09 10:43:35 EST
it's now fixed in redhat-artwork-0.119-1.1E.

Note You need to log in before you can comment on or make changes to this bug.