Bug 137414 - Error in vmstat manpage (bi vs. bo column)
Summary: Error in vmstat manpage (bi vs. bo column)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procps   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 132991
TreeView+ depends on / blocked
 
Reported: 2004-10-28 12:30 UTC by Michael Paesold
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 03:25:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:156 normal SHIPPED_LIVE procps bug fix update 2005-05-19 04:00:00 UTC

Description Michael Paesold 2004-10-28 12:30:05 UTC
From Bugzilla Helper:
User-Agent: Opera/7.54 (Windows NT 5.1; U)  [en]

Description of problem:
The manpage for vmstat gets the field description of "bi" and "bo" 
wrong, here it says:

bi: Blocks sent to a block device (blocks/s).
bo: Blocks received from a block device (blocks/s).

But it should be the other way round, really:
bi = blocks in (from CPU perspective)
bo = blocks out (from CPU perspective)

Test youself, that is what vmstat really displays:
bi: Blocks received from a block device (blocks/s).
bo: Blocks sent to a block device (blocks/s).

This seems to be wrong in every release of RedHat linux we have.
It is correct on some other unices.

Version-Release number of selected component (if applicable):
procps-2.0.17-10

How reproducible:
Always

Steps to Reproduce:
Look at the manpage for vmstat and look at the FIELDS description, 
specifically io -- bi and bo;
then test yourself on an otherwise idle system:
dd if=/dev/zero of=/tmp/testfile bs=1024 count=200000 & vmstat 1 10

You will clearly see, that the manual page is wrong.

Comment 1 Karel Zak 2004-12-07 12:30:24 UTC
It will be fixed in RHEL-3-U5. 

Comment 2 Dennis Gregorovic 2005-05-20 03:25:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-156.html



Note You need to log in before you can comment on or make changes to this bug.