Bug 1374280 - rpc/xdr: generated files are filtered with a sed extended regex
Summary: rpc/xdr: generated files are filtered with a sed extended regex
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1330604 1377341
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 11:45 UTC by Kaleb KEITHLEY
Modified: 2016-10-20 14:02 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1374278
: 1374281 (view as bug list)
Environment:
Last Closed: 2016-10-20 14:02:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2016-09-08 11:45:59 UTC
+++ This bug was initially created as a clone of Bug #1374278 +++

Description of problem:

Extended regex handling is enabled with -r command line option on linux.

NetBSD and FreeBSD use -E, but also provide -r for compatibility.

Mac OS X only accepts -E. As a result, building on Mac OS fails early. (There may be other issues with building on Mac OS.)

In any event, it's possible to do the job with an ordinary regex, extended regex isn't necessary.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-09-08 12:09:13 UTC
REVIEW: http://review.gluster.org/15429 (rpc/xdr: use ordinary regex to sed filter generated files) posted (#1) for review on release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2016-09-08 12:16:49 UTC
REVIEW: http://review.gluster.org/15429 (rpc/xdr: use ordinary regex to sed filter generated files) posted (#2) for review on release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2016-09-09 01:00:00 UTC
REVIEW: http://review.gluster.org/15429 (rpc/xdr: use ordinary regex to sed filter generated files) posted (#3) for review on release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Niels de Vos 2016-09-12 05:39:25 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 5 Worker Ant 2016-09-12 09:13:41 UTC
COMMIT: http://review.gluster.org/15429 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit e002798e8f85b67d67d34326b32f838541827bc5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Sep 8 08:08:15 2016 -0400

    rpc/xdr: use ordinary regex to sed filter generated files
    
    Versus an extended regex
    
    While NetBSD and FreeBSD's sed has compat -r command line option,
    Mac OS X's sed does not.
    
    And there's no need to use an extended regex here; avoiding extra
    logic to determine whether running on Linux or *BSD.
    
    Change-Id: I6089f994f6c4f50eb353fc018b1b678ec93d6626
    BUG: 1374280
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/15429
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 6 Niels de Vos 2016-10-20 14:02:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.5, please open a new bug report.

glusterfs-3.8.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-October/000061.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.