Bug 1374282 - python-neutron-tests require python-oslotest
Summary: python-neutron-tests require python-oslotest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Ihar Hrachyshka
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 11:48 UTC by Jakub Libosvar
Modified: 2016-12-14 15:58 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-9.0.0-1.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:58:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 2781 None None None 2016-10-14 17:00:28 UTC
OpenStack gerrit 367340 None None None 2016-09-22 16:18:21 UTC

Description Jakub Libosvar 2016-09-08 11:48:34 UTC
Description of problem:
We ship neutron-sanity-check with openstack-neutron while this executable requires neutron.tests module which is part of python-neutron-tests.

Also python-neutron-tests is missing dependency on python-oslotest

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ihar Hrachyshka 2016-09-08 12:12:37 UTC
I believe the right fix is to stop using the neutron.tests. namespace outside of neutron.tests.*

Comment 2 Ihar Hrachyshka 2016-09-08 13:13:09 UTC
FYI the fix for sanity-check dependency on neutron.tests.* is at: https://review.openstack.org/#/c/367340/

Comment 4 Toni Freger 2016-10-31 09:57:13 UTC
The code was verified on python-neutron-9.0.0-1.4.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 15:58:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.