Bug 1374389 - bash-completion for "rct stat-cert --<TAB><TAB>" should NOT show --no-content as an option
Summary: bash-completion for "rct stat-cert --<TAB><TAB>" should NOT show --no-content...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 14:39 UTC by John Sefler
Modified: 2017-08-01 19:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1487 None None None 2016-09-14 17:36:17 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2016-09-08 14:39:02 UTC
Description of problem:
It appears that the fix for Bug 1369522 was too agressive.
We want bash-completion for "rct cat-manifest --<TAB><TAB>" to show "-no-content".
We do NOT want bash-completion for "rct stat-cert --<TAB><TAB>" to show "-no-content".


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q --whatprovides `which rct`
subscription-manager-1.17.14-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# rct stat-cert --help
Usage: rct stat-cert [OPTIONS] CERT_FILE

Print certificate statistics and sizes

Options:
  -h, --help  show this help message and exit
[root@jsefler-rhel7 ~]# rct stat-cert --<TAB><TAB>
--help        --no-content  
[root@jsefler-rhel7 ~]# rct stat-cert --no-content 
Usage: rct stat-cert [OPTIONS] CERT_FILE

rct: error: no such option: --no-content
[root@jsefler-rhel7 ~]# 


Actual results:
  above you see that tab completion presents "--no-content" as a valid option to "rct stat-cert", but it is not.

Expected results:
  tab completion should not render "--no-content" as a viable option for "rct stat-cert", but it is a viable option for "rct cat-manifest"

Additional info:

Comment 1 Chris Snyder 2016-09-15 16:48:45 UTC
Moving the to MODIFIED as a PR has been accepted upstream that should make it for the first build of 7.4.

Comment 2 Chris Snyder 2016-09-15 17:01:18 UTC
Not cloning this bug to 6.9 as the fix for this will be included in the rebase from upstream for the first build of 6.9.

Comment 4 Rehana 2017-04-03 04:54:50 UTC
Retested on ,

subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


# rct stat-cert --<TAB><TAB> 

# rct stat-cert --help 

^^ Observed that rct stat-cert --<TAB><TAB> now automatically  presents "help" as as option as its the only option available for the command 

# rct stat-cert -<TAB><TAB>
-h      --help  

Also verified that rct can-manifest --<TAB><TAB> continues to show its valid options 

# rct cat-manifest --<TAB><TAB>
--help        --no-content  

Marking as Verified!!

Comment 5 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.