Bug 1374403 - Location of Finishing off is incorrect and failed to set image properties when convert guest to glance by virt-v2v
Summary: Location of Finishing off is incorrect and failed to set image properties whe...
Keywords:
Status: CLOSED DUPLICATE of bug 1374405
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 15:25 UTC by mxie@redhat.com
Modified: 2016-09-13 13:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 13:28:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
v2v-glance.log (840.08 KB, text/plain)
2016-09-08 15:25 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2016-09-08 15:25:17 UTC
Created attachment 1199147 [details]
v2v-glance.log

Description of problem:
Location of Finishing off is incorrect and failed to set image properties when convert guest to glance by virt-v2v

Version-Release number of selected component (if applicable):
virt-v2v-1.32.7-3.el7.x86_64
libguestfs-1.32.7-3.el7.x86_64
qemu-kvm-1.5.3-122.el7.x86_64
libvirt-2.0.0-8.el7.x86_64


How reproducible:
100% 

Steps to Reproduce:
1.Convert a guest from xen to glance by virt-v2v
[root@localhost ~(keystone_admin)]# virt-v2v -ic xen+ssh://root@10.73.3.21 xen-hvm-rhel7.2-x86_64 -o glance -of qcow2
[   0.0] Opening the source -i libvirt -ic xen+ssh://root@10.73.3.21 xen-hvm-rhel7.2-x86_64
[   0.5] Creating an overlay to protect the source from being modified
[   1.3] Initializing the target -o glance
[   1.9] Opening the overlay
[   4.2] Inspecting the overlay
[  17.0] Checking for sufficient free disk space in the guest
[  17.0] Estimating space required on target for each disk
[  17.0] Converting Red Hat Enterprise Linux Server 7.2 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 119.2] Mapping filesystem data to avoid copying unused and blank areas
[ 119.3] Closing the overlay
[ 119.4] Checking if the guest needs BIOS or UEFI to boot
[ 119.4] Assigning disks to buses
[ 119.4] Copying disk 1/1 to /var/tmp/glance.i0ZsGw/sda (qcow2)
    (100.00/100%)
[ 394.1] Creating output metadata
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | e3245bb63a9b7fb28ccaff5b27dc85f3     |
| container_format | bare                                 |
| created_at       | 2016-09-08T14:23:49Z                 |
| disk_format      | qcow2                                |
| id               | 62b74870-b32d-4f2a-9375-7615efdd20e3 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | xen-hvm-rhel7.2-x86_64               |
| owner            | 6c4dac53186d44fcbac29d3f3f575125     |
| protected        | False                                |
| size             | 3712286720                           |
| status           | active                               |
| tags             | []                                   |
| updated_at       | 2016-09-08T14:24:29Z                 |
| virtual_size     | None                                 |
| visibility       | private                              |
+------------------+--------------------------------------+
404 Not Found: No image found with ID xen-hvm-rhel7.2-x86_64 (HTTP 404)
virt-v2v: warning: glance: failed to set image properties (ignored)
[ 443.5] Finishing off
Image properties:
  --min-ram 1024
  --property 'os_version'='7.2'  --property 'hw_disk_bus'='virtio'  --property 'hw_vif_model'='virtio'  --property 'architecture'='x86_64'  --property 'hypervisor_type'='kvm'  --property 'vm_mode'='hvm'  --[r
2.Found that location of Finishing off is incorrect and v2v failed to set image properties when convert guest to glance

 
Actual results:
As above description

Expected results:
Location of Finishing off is correct and set image properties normally when convert guest to glance by virt-v2v

Additional info:
1.Can't reproduce this bug when using below version of packages to convert guest to glance,details log pls refer to https://bugzilla.redhat.com/show_bug.cgi?id=1321302

Packages:
virt-v2v-1.32.3-1.el7.x86_64
libguestfs-1.32.3-1.el7.x86_64
libvirt-1.3.2-1.el7.x86_64
qemu-kvm-1.5.3-109.el7.x86_64

Steps:
1.1 # virt-v2v rhel5.11-mxie -on default-raw -o glance -of raw 
[   0.0] Opening the source -i libvirt rhel5.11-mxie
[   0.0] Creating an overlay to protect the source from being modified
[   0.3] Initializing the target -o glance
[   4.4] Opening the overlay
[   7.2] Inspecting the overlay
[  12.3] Checking for sufficient free disk space in the guest
[  12.3] Estimating space required on target for each disk
[  12.3] Converting Red Hat Enterprise Linux Server release 5.11 (Tikanga) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[  22.2] Mapping filesystem data to avoid copying unused and blank areas
[  22.4] Closing the overlay
[  22.4] Checking if the guest needs BIOS or UEFI to boot
[  22.4] Assigning disks to buses
[  22.4] Copying disk 1/1 to /var/tmp/glance.Chzy72/sda (raw)
    (100.00/100%)
[  97.9] Creating output metadata
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | db789ec06a608f4b0974b798b346739f     |
| container_format | bare                                 |
| created_at       | 2016-03-25T09:06:18.000000           |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | raw                                  |
| id               | 958ba435-5487-44b8-a23e-039e6c242361 |
| is_public        | False                                |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | default-raw                          |
| owner            | 6c4dac53186d44fcbac29d3f3f575125     |
| protected        | False                                |
| size             | 6442450944                           |
| status           | active                               |
| updated_at       | 2016-03-25T09:07:39.000000           |
| virtual_size     | None                                 |
+------------------+--------------------------------------+
+----------------------------+--------------------------------------+
| Property                   | Value                                |
+----------------------------+--------------------------------------+
| Property 'architecture'    | x86_64                               |
| Property 'hw_disk_bus'     | virtio                               |
| Property 'hw_vif_model'    | virtio                               |
| Property 'hypervisor_type' | kvm                                  |
| Property 'os_distro'       | rhel                                 |
| Property 'os_type'         | linux                                |
| Property 'os_version'      | 5.11                                 |
| Property 'vm_mode'         | hvm                                  |
| checksum                   | db789ec06a608f4b0974b798b346739f     |
| container_format           | bare                                 |
| created_at                 | 2016-03-25T09:06:18.000000           |
| deleted                    | False                                |
| deleted_at                 | None                                 |
| disk_format                | raw                                  |
| id                         | 958ba435-5487-44b8-a23e-039e6c242361 |
| is_public                  | False                                |
| min_disk                   | 0                                    |
| min_ram                    | 1024                                 |
| name                       | default-raw                          |
| owner                      | 6c4dac53186d44fcbac29d3f3f575125     |
| protected                  | False                                |
| size                       | 6442450944                           |
| status                     | active                               |
| updated_at                 | 2016-03-25T09:07:45.000000           |
| virtual_size               | None                                 |
+----------------------------+--------------------------------------+
[ 188.7] Finishing off

Comment 2 Pino Toscano 2016-09-12 16:11:39 UTC
This is most probably a duplicate of bug 1374405.

Comment 3 Pino Toscano 2016-09-13 13:28:59 UTC
(In reply to Pino Toscano from comment #2)
> This is most probably a duplicate of bug 1374405.

Indeed, the issue is the failure to address the newly created image => bug 1374405.

*** This bug has been marked as a duplicate of bug 1374405 ***


Note You need to log in before you can comment on or make changes to this bug.