Bug 1374406 - PS/2 mouse scrolling is backwards and cannot be changed
Summary: PS/2 mouse scrolling is backwards and cannot be changed
Keywords:
Status: CLOSED DUPLICATE of bug 1352159
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 15:31 UTC by Paul Eggert
Modified: 2016-11-01 05:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-01 05:32:49 UTC


Attachments (Terms of Use)

Description Paul Eggert 2016-09-08 15:31:32 UTC
Description of problem:

(This problem is really annoying.)

In my GNOME Desktop on Fedora 24, scrolling with the mousewheel is backwards from what it was on Fedora 23, or from what it is on Ubuntu. There does not seem to be a way for a user to change this (please see "Additional Info" below for what does not work).

Version-Release number of selected component (if applicable):

Fedora 24 x86-64, gnome-control-center 3.20.1-1.fc24.x86_64

How reproducible:

My desktop uses a Logitech M-SBJ96 (aka M-S48a) Pilot Wheel Mouse, part number 851208-1000. It is a 3-button, wired, PS/2 scroll mouse, where the middle button is the scroll wheel. Fedora 24 is running the command '/usr/sbin/gpm -m /dev/input/mice -t exps2'. 'ls -l /dev/input/mice' reports 13, 63 as major and minor device numbers.

Steps to Reproduce:
1. Log in normally.
2. Run Firefox on any long web page.
3. Rotate the top of the mouse wheel towards me.

Actual results:

The document scrolls to its beginning.

Expected results:

The document should scroll to its end.

Additional info:

The problem does not occur if I select a Wayland login. However, Wayland has another big problem (which I will report separately), so this is not an adequate workaround.

If I run "gnome-control-center mouse" and change the Natural Scroling setting, nothing happens; scrolling is still backwards from what I want.

Comment 1 Paul Eggert 2016-09-08 15:38:21 UTC
I switched to a USB mouse (Logitech Wireless Mouse M510, part number 810-001897) and the problem went away. So this appears to be a problem with PS/2 mice. Since I have a workaround it is no longer urgent for me, though I imagine it will continue to be offputting for other users with PS/2 mice.

Comment 2 Bastien Nocera 2016-10-05 16:20:25 UTC
Do you have either the evdev or synaptics xorg drivers installed?
What's the output of "sudo libinput-list-devices" with the device plugged in?

Comment 3 Paul Eggert 2016-10-05 16:39:00 UTC
(In reply to Bastien Nocera from comment #2)
> Do you have either the evdev or synaptics xorg drivers installed?

lsmod does not report either driver. Here is the lsmod output:

Module                  Size  Used by
fuse                  102400  3
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
ip6t_rpfilter          16384  1
ip6t_REJECT            16384  2
nf_reject_ipv6         16384  1 ip6t_REJECT
xt_conntrack           16384  21
ip_set                 36864  0
nfnetlink              16384  1 ip_set
ebtable_nat            16384  1
ebtable_broute         16384  1
bridge                131072  1 ebtable_broute
stp                    16384  1 bridge
llc                    16384  2 stp,bridge
ip6table_raw           16384  1
ip6table_mangle        16384  1
ip6table_security      16384  1
ip6table_nat           16384  1
nf_conntrack_ipv6      20480  12
nf_defrag_ipv6         36864  1 nf_conntrack_ipv6
nf_nat_ipv6            16384  1 ip6table_nat
iptable_raw            16384  1
iptable_mangle         16384  1
iptable_security       16384  1
iptable_nat            16384  1
nf_conntrack_ipv4      16384  11
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
nf_nat_ipv4            16384  1 iptable_nat
nf_nat                 28672  2 nf_nat_ipv4,nf_nat_ipv6
nf_conntrack          102400  8 nf_conntrack_netbios_ns,nf_nat,nf_nat_ipv4,nf_nat_ipv6,xt_conntrack,nf_conntrack_broadcast,nf_conntrack_ipv4,nf_conntrack_ipv6
ebtable_filter         16384  1
ebtables               32768  3 ebtable_broute,ebtable_nat,ebtable_filter
ip6table_filter        16384  1
ip6_tables             28672  5 ip6table_filter,ip6table_mangle,ip6table_security,ip6table_nat,ip6table_raw
kvm_amd                73728  0
kvm                   573440  1 kvm_amd
snd_hda_codec_via      24576  1
snd_hda_codec_hdmi     45056  4
snd_hda_codec_generic    73728  1 snd_hda_codec_via
snd_hda_intel          36864  12
irqbypass              16384  1 kvm
snd_hda_codec         126976  4 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel
k10temp                16384  0
snd_hda_core           81920  5 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_seq                69632  0
snd_seq_device         16384  1 snd_seq
snd_pcm               118784  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
acpi_cpufreq           20480  1
asus_atk0110           20480  0
snd_timer              32768  2 snd_pcm,snd_seq
sp5100_tco             16384  0
tpm_tis                20480  0
snd                    77824  34 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
shpchp                 36864  0
soundcore              16384  1 snd
tpm                    40960  1 tpm_tis
i2c_piix4              24576  0
nfsd                  331776  1
auth_rpcgss            61440  1 nfsd
nfs_acl                16384  1 nfsd
lockd                  94208  1 nfsd
grace                  16384  2 nfsd,lockd
sunrpc                319488  7 nfsd,auth_rpcgss,lockd,nfs_acl
ata_generic            16384  0
pata_acpi              16384  0
nouveau              1519616  7
video                  40960  1 nouveau
mxm_wmi                16384  1 nouveau
r8169                  81920  0
serio_raw              16384  0
mii                    16384  1 r8169
i2c_algo_bit           16384  1 nouveau
drm_kms_helper        143360  1 nouveau
pata_atiixp            16384  0
ttm                    90112  1 nouveau
drm                   344064  10 ttm,drm_kms_helper,nouveau
pata_jmicron           16384  0
wmi                    16384  2 mxm_wmi,nouveau
fjes                   28672  0



> What's the output of "sudo libinput-list-devices" with the device plugged in?

Device:           Power Button
Kernel:           /dev/input/event1
Group:            1
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           Power Button
Kernel:           /dev/input/event0
Group:            2
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event2
Group:            3
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           ImPS/2 BYD TouchPad
Kernel:           /dev/input/event3
Group:            4
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

Comment 4 Bastien Nocera 2016-10-06 12:10:57 UTC
(In reply to Paul Eggert from comment #3)
> (In reply to Bastien Nocera from comment #2)
> > Do you have either the evdev or synaptics xorg drivers installed?
> 
> lsmod does not report either driver. Here is the lsmod output:

Xorg drivers, not kernel drivers. The output of:
rpm -qa "*xorg*"
would show which Xorg drivers are installed.

> > What's the output of "sudo libinput-list-devices" with the device plugged in?
<snip>
> Device:           ImPS/2 BYD TouchPad
> Kernel:           /dev/input/event3
> Group:            4
> Seat:             seat0, default
> Capabilities:     pointer 
> Tap-to-click:     n/a
> Tap-and-drag:     n/a
> Tap drag lock:    n/a
> Left-handed:      disabled
> Nat.scrolling:    disabled
> Middle emulation: disabled
> Calibration:      n/a
> Scroll methods:   button
> Click methods:    none
> Disable-w-typing: n/a
> Accel profiles:   flat *adaptive
> Rotation:         n/a

The device is detected as a touchpad, so it probably won't work as expected. Reassigning to libinput for root-causing, though the problem might be in the kernel.

Comment 5 Paul Eggert 2016-10-06 14:42:59 UTC
(In reply to Bastien Nocera from comment #4)

> The output of:
> rpm -qa "*xorg*"
> would show which Xorg drivers are installed.

Here is the output. Both drivers that you mentioned are installed.

xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc24.x86_64
xorg-x11-utils-7.5-21.fc24.x86_64
xorg-x11-drv-openchrome-0.5.0-1.fc24.x86_64
xorg-x11-drv-intel-2.99.917-24.20160712.fc24.x86_64
xorg-x11-server-common-1.18.4-4.fc24.x86_64
xorg-x11-drv-synaptics-1.8.3-2.fc24.x86_64
xorg-x11-xbitmaps-1.1.1-9.fc24.noarch
xorg-x11-drv-wacom-0.32.0-2.fc24.x86_64
xorg-x11-xinit-1.3.4-11.fc24.x86_64
xorg-x11-drv-evdev-2.10.3-1.fc24.x86_64
xorg-x11-drv-fbdev-0.4.3-24.fc24.x86_64
xorg-x11-server-Xorg-1.18.4-4.fc24.x86_64
xorg-x11-xauth-1.0.9-5.fc24.x86_64
xorg-x11-drv-vmware-13.0.2-11.20150211git8f0cf7c.fc24.x86_64
abrt-addon-xorg-2.8.2-1.fc24.x86_64
xorg-x11-drv-libinput-0.19.0-2.fc24.x86_64
xorg-x11-drv-vesa-2.3.2-24.fc24.x86_64
xorg-x11-drv-vmmouse-13.1.0-3.fc24.x86_64
xorg-x11-server-utils-7.7-19.fc24.x86_64
xorg-x11-drv-qxl-0.1.4-7.fc24.x86_64
xorg-x11-server-Xwayland-1.18.4-4.fc24.x86_64
xorg-x11-xkb-utils-7.7-17.fc24.x86_64
xorg-x11-proto-devel-7.7-19.fc24.noarch
xorg-x11-font-utils-7.5-31.fc24.x86_64
xorg-x11-drv-nouveau-1.0.12-4.fc24.x86_64

Comment 6 Peter Hutterer 2016-11-01 05:32:49 UTC

*** This bug has been marked as a duplicate of bug 1352159 ***


Note You need to log in before you can comment on or make changes to this bug.