Bug 1374465 - rhel-osp-director: ceph mons don't start after reboot
Summary: rhel-osp-director: ceph mons don't start after reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ceph
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 18:00 UTC by Alexander Chuzhoy
Modified: 2016-12-14 15:59 UTC (History)
13 users (show)

Fixed In Version: puppet-ceph-2.1.0-0.20160926220714.c764ef8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:59:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 369136 None None None 2016-09-13 03:55:47 UTC
Launchpad 1622825 None None None 2016-09-13 03:55:16 UTC

Description Alexander Chuzhoy 2016-09-08 18:00:56 UTC
rhel-osp-director:   ceph mons don't start after reboot
Environment:
openstack-puppet-modules-9.0.0-0.20160802183056.8c758d6.el7ost.noarch
instack-undercloud-5.0.0-0.20160818065636.41ef775.el7ost.noarch
libcephfs1-10.2.2-38.el7cp.x86_64
ceph-radosgw-10.2.2-38.el7cp.x86_64
ceph-mon-10.2.2-38.el7cp.x86_64
ceph-common-10.2.2-38.el7cp.x86_64
python-cephfs-10.2.2-38.el7cp.x86_64
ceph-selinux-10.2.2-38.el7cp.x86_64
ceph-base-10.2.2-38.el7cp.x86_64
puppet-ceph-2.0.0-0.20160823145734.4e36628.1.el7ost.noarch
ceph-osd-10.2.2-38.el7cp.x86_64

Steps to reproduce:
1.
Deploy overcloud 10 with:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --swift-storage-scale 0 --block-storage-scale 0 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 1


network-environment.yaml has the following in it:
parameter_defaults:
  ExtraConfig:
    ceph::conf::args:
      global/osd_max_object_name_len:
        value: 256
      global/osd_max_object_namespace_len:
        value: 64


2. Reboot the overcloud nodes.
3. Check ceph status.

Result:
The ceph monitors are down and as a result, the ceph osd doesn't start on the ceph node.


Expected result:
The ceph monitors should start after reboot.

w/a:
Login to each mon host and run:
systemctl start ceph-mon@<hostname>

Comment 4 Yogev Rabl 2016-10-07 13:22:36 UTC
verified on puppet-ceph-2.2.0-1.el7ost.noarch

The Ceph monitor service is enabled in SystemD and is running after a reboot

Comment 7 errata-xmlrpc 2016-12-14 15:59:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.