Bug 1374558 - Laptop Brightness Oscillates Up/Down kernel-4.7.2-201.fc24
Summary: Laptop Brightness Oscillates Up/Down kernel-4.7.2-201.fc24
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-09-09 03:46 UTC by Garry T. Williams
Modified: 2016-09-28 18:36 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2016-09-28 18:36:20 UTC
Type: Bug

Attachments (Terms of Use)

Description Garry T. Williams 2016-09-09 03:46:27 UTC
Description of problem:
Laptop brightness oscillates bright/dim about once per second.  Laptop brightness keys are unresponsive.

No problem on previous kernel and ever for that matter.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot new kernel

Actual results: Screen brightness now oscillates bright/dim.  Brightness keys are ineffective.

Expected results: Screen brightness as before.  Keys work as before.

Additional info: Laptop is Dell XPS-13.

Comment 1 Roger Wells 2016-09-09 13:13:28 UTC
same kernel, no problem.
Laptop is Thinkpad X240, Intel graphics.

Comment 2 markzzzsmith 2016-09-14 02:15:38 UTC
I'm having the same problem, also with a Dell XPS-13. Didn't happen with former F24 4.6.7 kernel.

The once a second thing suggested that two different things were competing to set the screen brightness, and I also noticed that it started happening during boot.

I disabled both systemd-backlight and the xfce power manager, which stopped it, however the screen backlight was now at full brightness.

Actually, I've just noticed that under 4.6.7, the backlight directory under /sys/class/backlight is called 'acpi_video0', and has a max_brightness range up to 100, where as under 4.7.2 it had a name with 'intel' in it (I'll boot in a moment and check properly), and a max_brightness of up to around 4880.

This reminded me of this problem, although it seems to be in reverse - the ACPI backlight interface works correctly under 4.6.7, where as the switch to the Intel backlight interface is causing trouble.

Bit more research has shown that the kernel parameter 'acpi_backlight' parameter can be set to 'vendor' or 'video', with 'video' meaning use the ACPI video driver, which I think 4.6.7 is using. I'll give 'acpi_backlight=video' a go with 4.7.2.

(Given the much bigger range that the Intel video driver provides that might be the longer term better driver to use, although thats probably debatable.)

Comment 3 Garry T. Williams 2016-09-15 00:31:10 UTC
Still broken with 4.7.3-200.fc24 .

Comment 4 markzzzsmith 2016-09-15 06:13:54 UTC
I tried 'acpi_backlight' set to 'video', the 'acpi_video0' file reappeared, however 'intel_backlight' was also still there and the problem still existed.

I was unsuccessful in finding any instructions on how to disable the vendor backlight control, which I thought would restore just the use of 'acpi_video0' as the backlight control.

I think this case you have its priority and severity set above and to pretty high, as the only way to avoid this backlight flaring is to have the backlight set to full intensity, which will use up the battery very quickly. This issue basically makes 4.7.x kernels effectively unusable when running on battery (and running the backlight on full intensity on mains power isn't really much better either - full brightness is bright!)

Comment 5 markzzzsmith 2016-09-15 06:15:52 UTC
"I think this case you have its priority and severity set above and to pretty high,"

that went off the rails, I meant this case should have its priority and severity set pretty high because the issue is making 4.7.x kernels pretty much unusable in practice.

Comment 6 markzzzsmith 2016-09-15 06:17:29 UTC
This bug seems somewhat related, the thing that has changed between 4.6.x and 4.7.x is the appearance of the 'intel_backlight' file -

"Screen brightness adjustment stopped working with 4.7.2 kernel"

Comment 7 Talip Durmuş 2016-09-16 18:28:14 UTC
I have same problem with 4.7.2 and 4.7.3 kernel. We are waiting for hotfix.  THANKS

Comment 8 Garry T. Williams 2016-09-23 17:44:27 UTC
Same problem with 4.7.4-200 .

(I'll be running out of old kernels soon.)

Comment 9 markzzzsmith 2016-09-24 07:22:45 UTC
I locked my kernel upgrades using the versionlock dnf extension to stop 4.6.x being removed:


I've also tried a vanilla stable kernel of 4.7.x, and that is also still suffering from the problem.

Comment 10 markzzzsmith 2016-09-28 05:50:17 UTC
Just upgraded my system which included an upgrade to the vanilla 4.7.5 kernel (4.7.5-200.vanilla.knurd.1.fc24.x86_64). Problem seems to have been fixed, there is now only a single 'acpi_video0' file under /sys/class/backlight, and the periodic flaring has gone away.

I haven't been running it for long, 10 minutes or so, but it is looking good.

Comment 11 Garry T. Williams 2016-09-28 18:36:20 UTC
Fixed with 4.7.5-200.fc24 .

Note You need to log in before you can comment on or make changes to this bug.