Bug 137462 - calling system-config-services from a command line does not work
Summary: calling system-config-services from a command line does not work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: redhat-config-services   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-28 17:01 UTC by John Poelstra
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 14:12:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Poelstra 2004-10-28 17:01:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
Running redhat-config-services from a command prompt does nothing. The
GUI does not appear and command prompt is returned.

redhat-config-services is a soft link to serviceconf. If you call
serviceconf from a command line the GUI comes up as expected.

Version-Release number of selected component (if applicable):
serviceconf-0.6.6-1

How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-services froma command prompt
2.
3.
    

Actual Results:  nothing happens

Expected Results:  service configuration GUI should appear

Additional info: observed on ia64 and i386

Comment 1 Nils Philippsen 2004-10-29 14:12:24 UTC
The problem is that there is no file
/etc/security/console.apps/redhat-config-services with the same
contents as the serviceconf file in the same directory. Therefore
consolehelper doesn't know about a program named
redhat-config-services. I can see some workarounds:

- Use "serviceconf" as this is the advertised name of the program in
RHEL2.1 (after all the package is called serviceconf)
- "cp /etc/security/console.apps/serviceconf
/etc/security/console.apps/redhat-config-services"
- Start the program from the "Program/System/Service Configuration"
menu entry (as this in turn will call serviceconf)

I have fixed this in package CVS (so it will be in the next erratum),
but I won't issue an erratum just for that (because it's a pure
convenience problem and there are easy workarounds). Perhaps you might
want to open a BZ against usermode because it should rather give you
an error such as "I don't know anything about
`redhat-config-services´' than only dropping you back to the shell.


Note You need to log in before you can comment on or make changes to this bug.