Bug 1374671 - Aodh treshold alarm - 'Response' object has no attribute 'status'
Summary: Aodh treshold alarm - 'Response' object has no attribute 'status'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometerclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Eoghan Glynn
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-09 11:50 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:00 UTC (History)
10 users (show)

Fixed In Version: python-ceilometerclient-2.6.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:00:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 366773 None None None 2016-09-12 07:36:46 UTC

Description Yurii Prokulevych 2016-09-09 11:50:13 UTC
Description of problem:
-----------------------
Traceback during 'treshold' alarm evaluation:

2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold [-] alarm stats retrieval failed
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold Traceback (most recent call last):
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/aodh/evaluator/threshold.py", line 128, in _statistics
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     period=rule['period'])
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/ceilometerclient/v2/statistics.py", line 58, in list
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     q, p))
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/ceilometerclient/common/base.py", line 63, in _list
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     resp = self.api.get(url)
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 187, in get
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     return self.request(url, 'GET', **kwargs)
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/ceilometerclient/client.py", line 473, in request
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     raise exc.from_response(resp, body)
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold   File "/usr/lib/python2.7/site-packages/ceilometerclient/exc.py", line 122, in from_response
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold     cls = _code_map.get(response.status, HTTPException)
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold AttributeError: 'Response' object has no attribute 'status'
2016-09-09 11:42:18.967 27524 ERROR aodh.evaluator.threshold 


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-aodh-api-3.0.0-0.20160820003735.858f55c.el7ost.noarch
openstack-aodh-common-3.0.0-0.20160820003735.858f55c.el7ost.noarch
python-aodh-3.0.0-0.20160820003735.858f55c.el7ost.noarch
openstack-aodh-evaluator-3.0.0-0.20160820003735.858f55c.el7ost.noarch
puppet-aodh-9.1.0-0.20160822221805.75161dd.el7ost.noarch
openstack-aodh-listener-3.0.0-0.20160820003735.858f55c.el7ost.noarch
python-aodhclient-0.6.0-0.20160802210136.65d2e62.el7ost.noarch
openstack-aodh-notifier-3.0.0-0.20160820003735.858f55c.el7ost.noarch


Steps to Reproduce:
1. Overcloud depoloyed with next command:
openstack overcloud deploy \
--ntp-server clock.redhat.com \
--templates \
--control-scale 3 --compute-scale 1 --ceph-storage-scale 1 \
--libvirt-type qemu -e puppet-pacemaker.yaml \
-e storage-environment.yaml

2. Create treshold alarm:

aodh --debug alarm create \
--type threshold \
--name 'AClient-Threshold-1' \
--description 'AodhClient-Threshold-Alarm-1' \
--severity low \
--enabled True \
--alarm-action 'log://' \
--ok-action 'log://' \
--insufficient-data-action 'log://' \
--repeat-actions False \
--comparison-operator ge \
--evaluation-periods 3 \
--meter-name CustomMeter-1 \
--period 60 \
--statistic avg \
--threshold 4 \
--query 'resource_id=CustomMeter-Resource-1'

Comment 1 Mehdi ABAAKOUK 2016-09-12 07:37:38 UTC
ceilometerclient upstream release 2.6.1 fix it. Next OSP10 should have this version.

Comment 3 Yurii Prokulevych 2016-10-06 14:24:15 UTC
Verified with python-ceilometerclient-2.6.1-1.el7ost.noarch

The traceback is not present in evaluator.log

Comment 6 errata-xmlrpc 2016-12-14 16:00:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.