Bug 1374690 - Traceback during metricd restart
Summary: Traceback during metricd restart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cotyledon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-09 12:31 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:00 UTC (History)
10 users (show)

Fixed In Version: python-cotyledon-1.2.7-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, a bug in an older version of `cotyledon` caused `metricsd` to not start properly and throw a traceback. This update includes a newer 1.2.7-2 `cotyledon` package. As a result, no traceback occurs and `metricsd` starts correctly.
Clone Of:
Environment:
Last Closed: 2016-12-14 16:00:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Yurii Prokulevych 2016-09-09 12:31:24 UTC
Description of problem:
-----------------------

During openstack-gnocchi-metricd restart traceback is logged:

2016-09-09 12:25:33.829 9761 INFO cotyledon [-] Caught SIGTERM signal, graceful exiting of service processing(0) [9761]
2016-09-09 12:25:33.829 9761 ERROR cotyledon [-] Unhandled exception
2016-09-09 12:25:33.829 9761 ERROR cotyledon Traceback (most recent call last):
2016-09-09 12:25:33.829 9761 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 62, in _exit_on_exception
2016-09-09 12:25:33.829 9761 ERROR cotyledon     yield
2016-09-09 12:25:33.829 9761 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 150, in _clean_exit
2016-09-09 12:25:33.829 9761 ERROR cotyledon     self.terminate()
2016-09-09 12:25:33.829 9761 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 107, in terminate
2016-09-09 12:25:33.829 9761 ERROR cotyledon     self.close_services()
2016-09-09 12:25:33.829 9761 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 291, in close_services
2016-09-09 12:25:33.829 9761 ERROR cotyledon     self.queue.close()
2016-09-09 12:25:33.829 9761 ERROR cotyledon AttributeError: 'AutoProxy[Queue]' object has no attribute 'close'
2016-09-09 12:25:33.829 9761 ERROR cotyledon 
2016-09-09 12:25:33.830 9762 INFO cotyledon [-] Caught SIGTERM signal, graceful exiting of service reporting(0) [9762]
2016-09-09 12:25:33.831 9762 ERROR cotyledon [-] Unhandled exception
2016-09-09 12:25:33.831 9762 ERROR cotyledon Traceback (most recent call last):
2016-09-09 12:25:33.831 9762 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 62, in _exit_on_exception
2016-09-09 12:25:33.831 9762 ERROR cotyledon     yield
2016-09-09 12:25:33.831 9762 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 150, in _clean_exit
2016-09-09 12:25:33.831 9762 ERROR cotyledon     self.terminate()
2016-09-09 12:25:33.831 9762 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 107, in terminate
2016-09-09 12:25:33.831 9762 ERROR cotyledon     self.close_services()
2016-09-09 12:25:33.831 9762 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 113, in close_services
2016-09-09 12:25:33.831 9762 ERROR cotyledon     raise NotImplementedError
2016-09-09 12:25:33.831 9762 ERROR cotyledon NotImplementedError
2016-09-09 12:25:33.863 9762 ERROR cotyledon [-] unexpected atexit exception
2016-09-09 12:25:33.863 9762 ERROR cotyledon Traceback (most recent call last):
2016-09-09 12:25:33.863 9762 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 53, in _logged_sys_exit
2016-09-09 12:25:33.863 9762 ERROR cotyledon     atexit._run_exitfuncs()
2016-09-09 12:25:33.863 9762 ERROR cotyledon   File "/usr/lib64/python2.7/atexit.py", line 24, in _run_exitfuncs
2016-09-09 12:25:33.863 9762 ERROR cotyledon     func(*targs, **kargs)
2016-09-09 12:25:33.863 9762 ERROR cotyledon   File "/usr/lib64/python2.7/multiprocessing/util.py", line 319, in _exit_function
2016-09-09 12:25:33.863 9762 ERROR cotyledon     p.join()
2016-09-09 12:25:33.863 9762 ERROR cotyledon   File "/usr/lib64/python2.7/multiprocessing/process.py", line 143, in join
2016-09-09 12:25:33.863 9762 ERROR cotyledon     assert self._parent_pid == os.getpid(), 'can only join a child process'
2016-09-09 12:25:33.863 9762 ERROR cotyledon AssertionError: can only join a child process
2016-09-09 12:25:33.863 9762 ERROR cotyledon 
2016-09-09 12:25:33.874 9760 DEBUG futurist.periodics [-] Stopped running 1 callbacks:
+--------------------------+------+----------+-----------+-----------------+-------------------------+
|           Name           | Runs | Failures | Successes | Average elapsed | Average elapsed waiting |
+--------------------------+------+----------+-----------+-----------------+-------------------------+
| gnocchi.cli.run_watchers | 163  |    0     |    163    |     0.0539s     |         0.0009s         |
+--------------------------+------+----------+-----------+-----------------+-------------------------+ _on_finish /usr/lib/python2.7/site-packages/futurist/periodics.py:707



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-gnocchi-indexer-sqlalchemy-2.2.1-0.20160821103314.7a40269.el7ost.noarch
openstack-gnocchi-metricd-2.2.1-0.20160821103314.7a40269.el7ost.noarch
puppet-gnocchi-9.1.0-0.20160815142605.7aa0c60.el7ost.noarch
python-gnocchi-2.2.1-0.20160821103314.7a40269.el7ost.noarch
openstack-gnocchi-api-2.2.1-0.20160821103314.7a40269.el7ost.noarch
python-gnocchiclient-2.5.1-0.20160823092719.a1ec8aa.el7ost.noarch
openstack-gnocchi-carbonara-2.2.1-0.20160821103314.7a40269.el7ost.noarch
openstack-gnocchi-common-2.2.1-0.20160821103314.7a40269.el7ost.noarch
openstack-gnocchi-statsd-2.2.1-0.20160821103314.7a40269.el7ost.noarch


Steps to Reproduce:
-------------------
1. Deploy overcopenstack overcloud deploy \
--ntp-server clock.redhat.com \
--templates \
--control-scale 3 --compute-scale 1 --ceph-storage-scale 1 \
--libvirt-type qemu -e puppet-pacemaker.yaml \
-e storage-environment.yaml loud:

2. Enabled debug in gnocchi.conf and restart service:
    systemctl restart openstack-gnocchi-metricd.service

Comment 1 Julien Danjou 2016-09-09 12:57:44 UTC
This is a bug in Cotyledon that has been fixed upstream. We need the package to be updated I think.

Comment 2 Julien Danjou 2016-09-09 12:58:36 UTC
Which version of Cotyledon do you have installed Yurii?

Comment 3 Yurii Prokulevych 2016-09-09 13:03:22 UTC
python-cotyledon-1.2.5-0.1.pre_review.el7ost.noarch

Comment 4 Pradeep Kilambi 2016-09-09 13:17:21 UTC
You need python-cotyledon 1.2.7, we rebased it in rdo repos. I'll poke jjoyce to pull it in.

Comment 6 Yurii Prokulevych 2016-10-06 13:31:18 UTC
Verified with python-cotyledon-1.2.7-2.el7ost.noarch

No traceback during service's restart.

Comment 8 errata-xmlrpc 2016-12-14 16:00:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.