Bug 137477 - non-writable desktop icons
non-writable desktop icons
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 14:38 EDT by Brent Fox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 09:33:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2004-10-28 14:38:08 EDT
I hope I do a decent enough job of explaining this problem...

When I drag a menu item from the Main Menu to the desktop, I get a
little icon that shows that the .desktop file I just created in my
~/Desktop directory is read-only.  This is irritating from a
user-interface point of fiew, because the user doesn't think of this
icon as a file, they think of it soley as an application launcher.  It
seems to me that the action of dragging a menu item from the main menu
should automatically chmod the file to 600.

Additionally, the behavior is inconsistent if I drag the icon to the
panel before dragging it to the desktop.  For example, if I drag an
item from the Main Menu to the panel and release it, it appears in the
panel.  Then if I click and drag that icon from the panel to the
desktop, the permissions on the file will be 700.  

Shouldn't the file permissions work the same way if I'm dragging from
the menu to the desktop or from the panel to the desktop?
Comment 1 Mark McLoughlin 2004-10-29 10:23:38 EDT
Sounds odd alright
Comment 2 Marco Pesenti Gritti 2004-11-05 15:05:53 EST
Nautilus does a simple copy of the applications:///... file on the
desktop. Upstream the permission info field for the vfolder gnome-vfs
method is disabled, in our packages permission is 666 (because of our
vfolder patches). I guess it's read only to not allow editing.

I doubt we can do much about it in control-center. Reassigning to
nautilus (in the lack of any better solution I guess the handling of
the applications: uris could be special cased).
Comment 3 Marco Pesenti Gritti 2004-11-05 15:10:54 EST
s/control-center/gnome-panel :)
Comment 4 Marco Pesenti Gritti 2004-11-09 11:17:21 EST
I think the new implementation of menus on gnome-panel head fixes
this. Still if we want to do a work around for fc3/RHEL4 it should
probably be in nautilus.
Otherwise I guess we could verify and mark this upstream.
Comment 5 Alexander Larsson 2005-01-11 09:33:50 EST
Verified with cvs version of gnome.

Note You need to log in before you can comment on or make changes to this bug.