Bug 137487 - Norwegian translation includes som german texts + some more
Norwegian translation includes som german texts + some more
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 16:08 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.9.93-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-10-28 16:08:58 EDT
Description of problem:
In the Norwegian translation of OpenOffice 1.1.2, if you right-click a
 picture in a text, some of the menu that pops up are in german. Which
i pretty ugly...

btw. i just saw that some of the sub levels of that menu are in english...

Version-Release number of selected component (if applicable):
1.1.2

How reproducible:
Every time

Steps to Reproduce:
1. Put a picture into the text
2. right-click it
3. Some of the menu are in german...
  
Actual results:
partially german menu

Expected results:
all norwegian

Additional info:

It is the upper two menu entries.

Correct translations:

Current:
Anordnung -> "Sortering" (means "sort")
   (sub-menu correct norwegian)
Ausrichtung -> "Justering" (adjustment)
   (sub-menu: upper half in english)
      Left     -> Venstre
      Centered -> Sentrert
      Right    -> Høyre

The file -> New and file -> wizard are also untranslated. Here are my
suggestions:

Then "new" (Ny) menu:
   Text document   -> Tekstdokument
   Spreadsheet     -> Rompeark
   Presentation    -> Presentasjon
   Drawing         -> Tegning
   HTML document   -> HTML-dokument (OR "webside" OR "nettside")
   Master Document -> Hoveddokument (fuzzy)
   Formula         -> Formel
   Lables          -> Merkelapper (a bit fuzzy)
   Business Cards  -> Visittkort
   Templates and documents -> Maler og dokumenter (this is used on the
title of the acctual box that pops up)

the wizard (veiviser) menu:
   Letter -> Brev
   Fax    -> Faks
   Agenda -> tidsplan
   Memo   -> Notat
   Presentation -> presentasjon
   Web page -> Nettside
   Form   -> Skjema
   Report -> Rapport
   Document converter -> Dokumentkonvertering
   Euro converter -> Eurokonvertering
   Star Office 5.2 Document import -> Star Office 5.2 Dokumentinnport
   Install new dictionaries -> installer nye ordlister
   Install new fonts from the web -> Installer nye fonter fra internett

I certainly hope this get fixed for FC3 - german looks *very* stupid
in a norwegian program...
Comment 1 Kyrre Ness Sjøbæk 2004-11-01 13:49:35 EST
moved it to devel as people on the mailinglist has confirmed that the
bug is there as well...
Comment 2 Gaute Hvoslef Kvalnes 2004-11-04 13:22:04 EST
Norwegian language is not supported in OOo 1.1.2. (It's there, but there are several 
serious errors.)

If you're planning to ship Norwegian 1.1.2 translations, you should consider 
integrating the fix at http://www.openoffice.org/issues/show_bug.cgi?id=28927  It'll fix the 
most misleading errors. In 1.1.3, all of this is of course fixed. The error and the fix applies 
to both Norwegian Bokmal (nb) and Norwegian Nynorsk (nn).

Regards,
 Gaute Hvoslef Kvalnes
 Coordinator of the Norwegian OpenOffice.org translations
Comment 3 Kyrre Ness Sjøbæk 2004-11-04 17:36:46 EST
obiviously.

But in the meantime - if you plan to ship it anyway - please add those
translations - or switch those "bad" menues over to english. This is
not good. Most people can tolerate to have the manual in english, but
when a german menu suddely sticks its ugly head out (anobody who has
been forced through 5 years of german, knows how to seriously dislike
the language...)

Would be great if you did it before FC3-final - as i guess there will
be no update of OO just to accomodate those errors, how bad they may bee.

Gaute: When will OO be 1.1.3 ready? *just curious*
Comment 4 Gaute Hvoslef Kvalnes 2004-11-05 03:27:37 EST
> Gaute: When will OO be 1.1.3 ready? *just curious*

1.1.3 is already released.
Comment 5 Dan Williams 2004-11-05 09:22:06 EST
1.1.3 isn't getting release with FC3 because it wasn't out yet before
FC3 essentially "froze".  RelEng wasn't accepting new tarballs without
a very good reason, and 1.1.2 was "cooked" enough that I didn't want
to switch up to 1.1.3 anyway.  It should get released as an update to
FC3 in a couple weeks.
Comment 6 Kyrre Ness Sjøbæk 2004-11-05 11:34:27 EST
Nice! And it is properly tested etc? Why was there such a short time
between release of 1.1.2 and 1.1.3, while it seemed to last forever
before 1.1.2 came?

Anywhere to get the release-notes? I can't find them on the OO page...

When will rpm's hit rawhide?
Comment 7 Dan Williams 2004-11-05 11:55:38 EST
It was only 3 months upstream between each release:

03/2004 (30th): release OpenOffice.org 1.1.1
06/2004 (22nd): release OpenOffice.org 1.1.2
09/2004 (27th): release OpenOffice.org 1.1.3

OOo release engineering is trying to get the 3rd-level release to be
just about every 3 months.

http://download.openoffice.org/1.1.3/release_notes_1.1.3.html
Comment 8 Dan Williams 2004-11-08 12:11:59 EST
Do those translations fix the menu issue that this bug is filed about?
Comment 9 Dan Williams 2004-11-08 12:13:58 EST
The only place those upstream translations fix seems to be:

source\offapp\dialog\treeopt.src

Which doesn't seem like it would fix the menu mistranslations
above.... right?
Comment 10 Gaute Hvoslef Kvalnes 2004-11-08 12:49:45 EST
True. That fix only caters for the *critical* bugs (which Kyrre might not have discovered :)

The German and English texts appearing are an unfortunate side-effect of OOo's horrible 
translation framework. Most of these are fixed in 1.1.3. If there are any remaining, I think 
they are all in English.

The English strings "File - New" and "File - Wizard" are a different problem, I think. They 
are already translated, but they require a special hack to appear translated in multi-
language builds. In fact, I first saw that hack in Red Hat's RPMs... (RH 8.0, I think.) I used 
it when I built Debian packages of OOo 1.0.2 for Skolelinux.
Comment 11 Kyrre Ness Sjøbæk 2004-11-08 15:13:00 EST
Which bugs? :P

But yes, the most critical thing is those german texts. They are just
plain ugly...

*quote*
The only place those upstream translations fix seems to be:

source\offapp\dialog\treeopt.src

Which doesn't seem like it would fix the menu mistranslations
above.... right?
*/quote*

What do you mean? Are my *highly unofficial* translations wrong? Or is
there simply just nowhere to place them? (due to a sucking
translations system?)

*hoping for a quick fix*

And then - a totaly different question: Why are not the i18n-pack
split into multiple languages? So that i didn't have to install
swahili dictionaries? (nothing wrong with swahili, but i don't know
swahili, nobody using my computer knows swahili, and i generally don't
care about swahili translations and dictionaries... Just an example!)
That would make updating dictionaries and translations for one
language much simpler (and a smaller, more justificable download...)
Comment 12 Caolan McNamara 2005-03-29 05:08:04 EST
caolanm->Kyrre: for rawhide we have seperate langpacks for 1.9.X, one for each
language, and there are now nn_NO and nb_NO langpacks. So the seperation is
done, also the fallback langauge is english, so that's done. But *are* the
norwegian translations merged into the 2.0 beta series ? I see nearly nothing in
the source .sdfs which are actually translated into norwegian, I can't find an
english status at no.openoffice.org to see if this is intentional or not.
Comment 13 Kyrre Ness Sjøbæk 2005-03-29 12:54:35 EST
Err... I really don't know - i have nothing to do with openoffice at all (exept
using it), including translations.

Ill ask some questions on the norwegian translator mailing list, and point them
to this bug. Some of them will probably know...
Comment 14 Kyrre Ness Sjøbæk 2005-03-30 09:22:32 EST
I didn't get any fish in the "mailing list fishing pond", so after some more
research, i found out on the norwegian openoffice site
(http://no.openoffice.org/) that:
"OpenOffice.org 2.0 beta
Den første betaversjonen av OpenOffice.org 2.0 er lansert i dag. Omsetjingane
til nynorsk og bokmål er så godt som ferdige, og du finn dei på nedlastingssida."

Which translates to "the first betaversion of openoffice 2.0 vas lauched today.
The translations to nynorsk and bokmål are as good as finished, and you find
them on the download pages".

Those pages are to be found here:
http://no.openoffice.org/about-downloads.html

This is the first beta, but even so, things have surely progressed since then.
Ill go fish some more, see what i can find out.

Great that the langpacks has been split out!
Comment 15 Gaute Hvoslef Kvalnes 2005-03-30 11:58:47 EST
You're just being impatient, Kyrre, I've been CC-ed to this bug (and subscribed 
to that mailing list) all along :-)

The problem is that OpenOffice.org has a policy of doing one big translation 
merge before release, instead of incremental merges. So, although our 
translations are virtually finished, they won't be included in OOo's source code 
until OOo decides to do the merge. (This should affect most translations, not 
only Norwegian.)

Pavel Janík provides builds for us and a number of other translation teams, 
based on up-to-date GSI (SDF) files that he merge at build time. In this way, we 
work around the disadvantages of not being merged into the official source code 
yet. However, the situation is still difficult for those building beta versions 
from source themselves (including most Linux distributions, I presume).

For the record, the up-to-date Norwegian GSI files are here, periodically 
updated to the latest milestone release:

http://developer.skulelinux.no/~gautehk/GSI_nb.sdf.bz2
http://developer.skulelinux.no/~gautehk/GSI_nn.sdf.bz2
Comment 16 Caolan McNamara 2005-04-21 12:24:40 EDT
I'll pull in the updated translations into our next ooo2 rpm

Note You need to log in before you can comment on or make changes to this bug.