Bug 137501 - artifacts when printing text with colors
artifacts when printing text with colors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 17:33 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.12.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-27 13:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
just after starting vi (3.48 KB, image/png)
2004-10-28 17:35 EDT, Ulrich Drepper
no flags Details
After going to the end of the line (4.60 KB, image/png)
2004-10-28 17:37 EDT, Ulrich Drepper
no flags Details
after going one line down (4.03 KB, image/png)
2004-10-28 17:39 EDT, Ulrich Drepper
no flags Details

  None (edit)
Description Ulrich Drepper 2004-10-28 17:33:55 EDT
Description of problem:
I have seen this only with vim but it can hardly be a problem in vim since there
is no way to produce the output which I see.  I will attach three PNGs to show
the problem.  This is on x86 but it should not matter.

Version-Release number of selected component (if applicable):
gnome-terminal-2.7.3-1

How reproducible:
always

Steps to Reproduce:
1.don't use system font in g-t, use Monospace 9.  might be the case for others,
too, but I use this
2.run vi /boot/grub/grub.conf
3.
  
Actual results:
as seen in the attached pictures

Expected results:
clean output, no double prints

Additional info:
Comment 1 Ulrich Drepper 2004-10-28 17:35:59 EDT
Created attachment 105920 [details]
just after starting vi

This is how portions of the screen look like right after starting vi.  Look at
the end of the lines.
Comment 2 Ulrich Drepper 2004-10-28 17:37:30 EDT
Created attachment 105921 [details]
After going to the end of the line

Now the cursor is at the end of the line.  The '0' now becomes readable.
Comment 3 Ulrich Drepper 2004-10-28 17:39:24 EDT
Created attachment 105922 [details]
after going one line down

Proceeding to the next line (same column), the '5' becomes now readable, the
'0' is back to its sorry state.
Comment 4 Ulrich Drepper 2006-05-27 13:27:15 EDT
I haven't seen this is quite some time.  I'll just close it with reference to
the FC5 version.

Note You need to log in before you can comment on or make changes to this bug.