Bug 137506 - gst-launch-0.8 segfaults on x86_64 with artsdsnk
gst-launch-0.8 segfaults on x86_64 with artsdsnk
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 18:33 EDT by Edward Rousseau
Modified: 2015-04-12 19:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 08:51:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user backtrace (3.45 KB, text/plain)
2004-10-28 18:36 EDT, Edward Rousseau
no flags Details

  None (edit)
Description Edward Rousseau 2004-10-28 18:33:41 EDT
Description of problem:
This problem is seen by choosing the Multimedia Systems Selector from
the Hat->Preferences->More Preferences menu. If I change Audio Default
sink from ALSA to Artsd and press test I get a segfault message in
/var/log/messages and the Gstreamer Preferences window goes away.
kernel: gstreamer-prope[4284]: segfault at 0000000000002198 rip
0000002a99b646ce rsp 0000007fbfffd7c0 error 6 is the message.

If I run gstreamer-properties from a terminal as my user and click
test I get the segfault. If I run the same command under a root
terminal the error dialog appears.

Running the command: gst-launch-0.8 sinesrc ! spider ! artsdsink

as root results in an error. Running it as a user results in a segfault.

See below for environment.


Version-Release number of selected component (if applicable):
gst-launch-0.8

How reproducible:
always

Steps to Reproduce:
1. run gst-launch-0.8 sinesrc ! spider ! artsdsink under a users terminal.
2.
3.
  
Actual results:
crash and segfault

Expected results:
Failed to construct test pipeline for 'Artsd - ART Sound Daemon' error
dialog appears

Additional info:

This appears to be x86_64 only. Additionally I have an unsupported
sound card so I have no sound. Multimedia audio controller: Intel
Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02). The box
is an EM64T. The way this issue was found would be close to the steps
a not so savy user would take trying to get sound working on the box IMO.

Backtrace attached.
Comment 1 Edward Rousseau 2004-10-28 18:36:30 EDT
Created attachment 105924 [details]
user backtrace

This may not be as useful because x86_64 debuginfo packages do not seem to
exist ...
Comment 2 Bastien Nocera 2007-02-01 08:51:00 EST
We don't ship an arts plugin any more, closing.

Note You need to log in before you can comment on or make changes to this bug.