Bug 1375096 - dht: Update stbuf from servers having layout
Summary: dht: Update stbuf from servers having layout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.8.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1365740
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-12 07:43 UTC by Susant Kumar Palai
Modified: 2016-10-20 14:02 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1365740
Environment:
Last Closed: 2016-10-20 14:02:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2016-09-12 07:43:27 UTC
+++ This bug was initially created as a clone of Bug #1365740 +++

Description of problem:
 Update stbuf from servers with layout since this is an indication that the server is not a newly added brick. Otherwise uid/gid heal may choose the added brick as the source of heal.

--- Additional comment from Vijay Bellur on 2016-08-10 11:50:23 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Vijay Bellur on 2016-08-11 13:49:46 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Vijay Bellur on 2016-08-11 14:15:52 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#3) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2016-08-25 09:21:54 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#4) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2016-09-06 12:05:35 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#5) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2016-09-06 17:59:43 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#6) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2016-09-09 11:14:28 MVT ---

REVIEW: http://review.gluster.org/15126 (dht: udpate stbuf from servers those have layout) posted (#7) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Worker Ant on 2016-09-09 17:20:25 MVT ---

COMMIT: http://review.gluster.org/15126 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 36af81ac7cb2d459f9bfc0c436f0038a68f85235
Author: Susant Palai <spalai@redhat.com>
Date:   Mon Aug 8 17:05:10 2016 +0530

    dht: udpate stbuf from servers those have layout
    
    Problem: For healing of uid/gid we check if local->stbuf.ia_ctime is
    lesser than stbuf->ia_ctime (received from brick). If yes then uid/gid
    is updated to local->prebuf(source of healing).
    
    But we merge local->stbuf also form the newly added brick. So if we
    receive response from the newly added brick first and update the
    local->stbuf, then local->prebuf will remain empty since the newly added
    brick will have the latest ctime among all servers. And this can result
    in healing wrong uid/gids to the rest of servers.
    
    Hence, we should update local->stbuf from servers with a layout which
    will ignore merging stbufs from newly added bricks.
    
    Change-Id: If4b64f75a0ea669abdbe9f5a3d1d18ff19374c2f
    BUG: 1365740
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/15126
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 1 Worker Ant 2016-09-12 07:50:19 UTC
REVIEW: http://review.gluster.org/15464 (dht: udpate stbuf from servers those have layout) posted (#1) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2016-09-15 11:16:02 UTC
REVIEW: http://review.gluster.org/15464 (dht: udpate stbuf from servers those have layout) posted (#2) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 3 Worker Ant 2016-09-29 05:02:30 UTC
REVIEW: http://review.gluster.org/15464 (dht: udpate stbuf from servers those have layout) posted (#3) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 4 Worker Ant 2016-09-29 09:37:19 UTC
COMMIT: http://review.gluster.org/15464 committed in release-3.8 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 9e4135c46455da7fe67c5ef61e098428cd238e95
Author: Susant Palai <spalai@redhat.com>
Date:   Mon Aug 8 17:05:10 2016 +0530

    dht: udpate stbuf from servers those have layout
    
    Problem: For healing of uid/gid we check if local->stbuf.ia_ctime is
    lesser than stbuf->ia_ctime (received from brick). If yes then uid/gid
    is updated to local->prebuf(source of healing).
    
    But we merge local->stbuf also form the newly added brick. So if we
    receive response from the newly added brick first and update the
    local->stbuf, then local->prebuf will remain empty since the newly added
    brick will have the latest ctime among all servers. And this can result
    in healing wrong uid/gids to the rest of servers.
    
    Hence, we should update local->stbuf from servers with a layout which
    will ignore merging stbufs from newly added bricks.
    
    > Reviewed-on: http://review.gluster.org/15126
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit 36af81ac7cb2d459f9bfc0c436f0038a68f85235)
    
    Change-Id: If4b64f75a0ea669abdbe9f5a3d1d18ff19374c2f
    BUG: 1375096
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/15464
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Niels de Vos 2016-10-20 14:02:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.5, please open a new bug report.

glusterfs-3.8.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-October/000061.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.