Bug 1375175 - app windows grow with each start due to incorrectly using gtk API + wayland
Summary: app windows grow with each start due to incorrectly using gtk API + wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-09-12 11:56 UTC by Kamil Páral
Modified: 2016-12-16 21:00 UTC (History)
3 users (show)

Fixed In Version: virt-manager-1.4.0-5.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-16 21:00:23 UTC


Attachments (Terms of Use)

Description Kamil Páral 2016-09-12 11:56:00 UTC
Description of problem:
Since gtk3-3.21.5-1.fc25.x86_64 virt-manager windows grow with each start. You can see it at:
https://www.youtube.com/watch?v=NO6Wlaoq0x8

This has been reported against gtk:
https://bugzilla.gnome.org/show_bug.cgi?id=771112
and determined as an application bug:
https://bugzilla.gnome.org/show_bug.cgi?id=771112#c7

Quoting how to fix this:

~~~
https://wiki.gnome.org/HowDoI/SaveWindowState

Querying the window size and then setting it with GtkWindow API is perfectly fine.

Querying the window size with GtkWidget API and then setting it with GtkWindow API, *or* querying the window size with GtkWindow API and then setting it with GtkWidget API, is *not* okay, and only worked up until now with server-side decorations only on X11.
~~~

Version-Release number of selected component (if applicable):
virt-manager-1.4.0-3.fc25.noarch

How reproducible:
always

Steps to Reproduce:
1. start and close virt-manager repeatedly, it will grow each time

Additional info:
I see the problem not just with main virt-manager window, but also with a VM window (it's taller than it should be, even if you use "resize to VM" from menu).

Comment 1 Kamil Páral 2016-09-12 11:56:42 UTC
I forgot to mention this only happens on Wayland.

Comment 2 Cole Robinson 2016-12-13 18:28:59 UTC
Thanks Kamil for tracking down the issue! Made my life easy :) Fixed upstream now:

commit 035bdce9fde810dedb484054dd0d2778a88b7f4f
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Dec 13 13:27:06 2016 -0500

    manager: Fix window size tracking on wayland (bug 1375175)

Comment 3 Fedora Update System 2016-12-13 19:01:33 UTC
virt-manager-1.4.0-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f3f704d241

Comment 4 Kamil Páral 2016-12-14 08:55:36 UTC
Seems to be working great. Thanks, Cole.

Comment 5 Fedora Update System 2016-12-15 05:06:07 UTC
virt-manager-1.4.0-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f3f704d241

Comment 6 Fedora Update System 2016-12-16 21:00:23 UTC
virt-manager-1.4.0-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.