Bug 137518 - Pagetable leak making machine useless
Pagetable leak making machine useless
Status: CLOSED DUPLICATE of bug 132947
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 01:42 EDT by Benny Amorsen
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benny Amorsen 2004-10-29 01:42:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
The amount of memory used for pagetables constantly increases, until
the system starts swapping. Eventually the OOM killer gets rid of
processes, but the amount used never goes down significantly. I
checked the amount frequently during shutdown with SysRq-M, and it was
stuck around 210000 pages on a 1GB athlon64.

This seems to indicate that the leak is not due to a user space program.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.640 and kernel-2.6.9-1.643

How reproducible:
Always

Steps to Reproduce:
1. Boot
2. Wait a day or two
3. Listen to hard drive constantly seeking and watch machine become
gradually useless
    

Additional info:
Comment 1 Warren Togami 2004-10-29 02:36:41 EDT
Is your problem Bug #132947?  Try the patch there.
Comment 2 Benny Amorsen 2004-10-29 03:56:08 EDT
I think this is a dupe yes, sorry. I haven't yet tried the patch,
since a rebuild of the kernel rpm ends up saying:

gpg: no default secret key: secret key not available.

Once I figure out how to get around that, I'll try the patch.
Comment 3 Warren Togami 2004-10-29 03:57:01 EDT

*** This bug has been marked as a duplicate of 132947 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.