Bug 1375181 - /var/tmp/rpm-tmp.KPCugR: line 2: /bin/systemctl: No such file or directory
Summary: /var/tmp/rpm-tmp.KPCugR: line 2: /bin/systemctl: No such file or directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1376385 1376396 1376461 1377062
TreeView+ depends on / blocked
 
Reported: 2016-09-12 12:15 UTC by Milind Changire
Modified: 2017-03-06 17:26 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1350694
: 1376385 1376396 1376461 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:26:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Milind Changire 2016-09-12 12:18:02 UTC
Problem:
On systemd platforms, the glusterfs packages seem to get installed before systemd package gets installed breaking the install process. This needs to be fixed.

Solution:
Add "Requires: systemd" directive to primary glusterfs package for systemd platforms.

Comment 2 Worker Ant 2016-09-12 12:19:47 UTC
REVIEW: http://review.gluster.org/15469 (build: add systemd dependency) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 3 Worker Ant 2016-09-12 12:22:07 UTC
REVIEW: http://review.gluster.org/15469 (build: add systemd dependency) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

Comment 4 Worker Ant 2016-09-12 16:53:38 UTC
REVIEW: http://review.gluster.org/15469 (build: add systemd dependency) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)

Comment 5 Worker Ant 2016-09-13 08:55:19 UTC
REVIEW: http://review.gluster.org/15469 (build: add systemd dependency) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)

Comment 6 Worker Ant 2016-09-15 03:04:59 UTC
COMMIT: http://review.gluster.org/15469 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 73c6c2c307c8bcaac51aa94b1af518955f35d1b8
Author: Milind Changire <mchangir@redhat.com>
Date:   Tue Sep 13 14:21:29 2016 +0530

    build: add systemd dependency
    
    Installs break with glusterfs getting installed before systemd
    installation. This patch adds a dependency for systemd appropriately
    for Fedora and RHEL platforms for glusterfs-server and glusterfs-events
    packages.
    
    Change-Id: Ica18f82a5e37c7755f0d386ce2ac6c70e8082815
    BUG: 1375181
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/15469
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 7 Shyamsundar 2017-03-06 17:26:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.