Bug 13752 - gftp [really ftpd] not working properly with localhost
gftp [really ftpd] not working properly with localhost
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-11 17:08 EDT by Mick Tantasirikorn
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 01:40:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mick Tantasirikorn 2000-07-11 17:08:25 EDT
Tried using gftp to point to localhost and could not go into any 
directory.  The file name is incorrect.  but I have no problem connecting 
elsewhere.
Comment 1 Havoc Pennington 2000-07-13 15:19:38 EDT
Works fine for me, I need more details to reproduce the problem.
Comment 2 Mick Tantasirikorn 2000-07-14 10:03:18 EDT
On any particular system.
in Gnome, start gFTP
in Host: localhost
in port: 21
in user: anonymous
in password: <your E-mail>
in drop down box choose FTP

press enter

in the right window you should see date and time as well as either pub, lib, 
bin and etc as file name
for example
the file name is "13 17:25 lib" not just "lib"
when you try to double click it the message on the bottom of the screen says:

"CWD /13 17:25 lib"
"550 /13 17:25 lib: No such file or directory"
Comment 3 John Cagle 2000-07-18 20:55:07 EDT
This is not a problem with gftp.  It seems to be caused by 'ftpd', which puts extra "@" characters in its "DIR" output.  (You can test this yourself by just 
using command line 'ftp' to localhost.  Do a "DIR" command in any directory and you will see two extra @'s.)  gftp then parses the output incorrectly, 
resulting in the hosed filenames...

This behavior of ftpd (extra @'s) is different than the ftpd shipped with Red Hat 6.2.

Henceforth, I'm moving this to component 'krb5', since ftpd is part of the krb5-workstation-1.2.1-1 RPM.  I'm also changing the severity to HIGH since ftpd 
is a *major* component.
Comment 4 Havoc Pennington 2000-07-18 21:05:28 EDT
I'm reassigning the bug to the krb5 maintainer. Your report sounds plausible; I 
tried the gftp from Rawhide, but my system is still running ftpd from 6.2, so 
I didn't see the bug.
Comment 5 Nalin Dahyabhai 2000-07-21 15:09:04 EDT
ftp> dir
Running /usr/bin/ftp connecting to a current gssftpd:

200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 16
d--x--x--x    2 root     root         4096 Jul 20 20:13 bin
d--x--x--x    2 root     root         4096 Jul 20 20:13 etc
drwxr-xr-x    2 root     root         4096 Jul 21 18:56 lib
drwxr-sr-x    2 root     ftp          4096 Jul 12 11:31 pub
226 Transfer complete.
ftp> 

I can't reproduce this.
Comment 6 John Cagle 2000-07-21 20:17:13 EDT
This still happens on beta4.  I don't know why you
can't reproduce it.  I did a Custom install and
selected "Everything".

Once it boots up, edit /etc/ftpusers and remove 'root',
then FTP localhost as root, login, and you'll see the
extra @'s...

Also, what's gssftpd?  The one that runs on my system
is 'ftpd' from the krb5-workstation-1.2.1-7 RPM.
Comment 7 John Cagle 2000-07-21 20:18:56 EDT
230 User root logged in.
ftp> cd /tmp
250 CWD command successful.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for directory listing.
total 56
-rw-r--r--   1 root   @ root   @    20827 Jul 21 18:53 install.log
drwx------   2 root   @ root   @     4096 Jul 21 19:09 orbit-root
226 Transfer complete.
ftp: 145 bytes received in 0.00Seconds 145000.00Kbytes/sec.
ftp>
Comment 8 Nalin Dahyabhai 2000-07-24 01:40:39 EDT
The "gss" is short for generic security service, the authentication protocol
that wraps Kerberos authentication for FTP.  It sounded like a better choice
than krb5-ftpd at the time.  I've confirmed that the 5.60 server being connected
to is the krb5 ftpd and not wu-ftpd, and am using gftp-2.0.7pre3-3 and
krb5-workstation-1.2.1-7 for this test....

Oh, CRAP.  By default, the wu-ftpd server is enabled, not gssftpd, and it
*does* display this.  Passing the buck to the wu-ftpd package maintainer.
Comment 9 Nalin Dahyabhai 2000-07-24 02:08:40 EDT
Fixed in wu-ftpd-2.6.1-5.  Please reopen this bug if you find that
this continues to occur.
Comment 10 Nalin Dahyabhai 2000-07-24 02:09:13 EDT
Er, should've changed the component, too.

Note You need to log in before you can comment on or make changes to this bug.