Bug 137523 - Installer boot panics on CRC error in ramdisc decode
Installer boot panics on CRC error in ramdisc decode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 04:29 EDT by Paul Wayper
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 18:12:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wayper 2004-10-29 04:29:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Installing FC3test3 on a brand-new dual-Opteron machine from CD. 
After using any of the boot options, boot proceeds and panics after
trying to decode the ramdisk.  Here is the relevant section of the
boot process (hand-retyped):

...
RAMDISK: Compressed image found at block 0
crc error
VFS: Cannot open root device "<NULL>" or unknown-block (3,2)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on
unknown-block (3,2)

I've checked the md5sums and they are 100% correct wrt the downloaded
images.  I've also tried burning another CD (in case it was a media
error) with exactly the same results.  All options, such as 'linux
rescue' and 'linux text', do this, as it seems to be in the initial
image load.

Also worth noting: the Fedora logo did not show in the initial boot
screen.  This maybe another bug, but it may be a symptom related to
this one too.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD
2. Use any boot option

Actual Results:  Boot panics at ramdisk unpack as above.

Expected Results:  Boot continues successfully.

Additional info:
Comment 1 Paul Wayper 2004-10-29 04:44:45 EDT
Memory test shows no errors, machine uses ECC RAM so very unlikely
this is a RAM error.
Comment 2 Jeremy Katz 2004-10-29 09:29:08 EDT
I'd look for BIOS updates for your box.  This smells a lot like a BIOS
with buggy handling of the CD READ stuff.
Comment 3 Paul Wayper 2004-10-31 19:58:49 EST
Updated to latest BIOS (2.03), still has problem.  Fedora Core 2 i386
boots up fine on same machine (but I can't find the right drivers for
the Silicon Image 3114 SATA interface, so I can't install FC2 and
upgrade from there).
Comment 4 Paul Wayper 2004-10-31 22:23:54 EST
Also tried 'linux acpi=off', still has problem.
Comment 5 Paul Wayper 2004-11-01 00:45:20 EST
Also tried Fedora Core 3 test 2, still has (same) problem.
Comment 6 Paul Wayper 2004-11-01 18:12:38 EST
I knew it would be something simple.

It looks like a problem with the CD burner we're using here.  It
managed to burn the images badly in some way.  I burnt the same ISO
file to a CD on my home machine, brought it in to work and it worked
perfectly.

I'm sorry to have raised this issue and will now bury myself in soft
peat out of shame.

Note You need to log in before you can comment on or make changes to this bug.