Bug 1375269 - ipa trust-fetch-domains throws internal error
Summary: ipa trust-fetch-domains throws internal error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks: 1318169 1371915
TreeView+ depends on / blocked
 
Reported: 2016-09-12 15:01 UTC by Sudhir Menon
Modified: 2016-11-04 06:03 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:03:20 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-09-12 15:01:28 UTC
Description of problem:ipa trust-fetch-domains throws internal error


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-10.el7.x86_64
ipa-server-common-4.4.0-10.el7.noarch
ipa-server-dns-4.4.0-10.el7.noarch
ipa-server-trust-ad-4.4.0-10.el7.x86_64


How reproducible: Always


Steps to Reproduce:
1. Add trust 
2. run ipa trust-fetch-domains


Actual results:
[root@master samba]# ipa trust-fetch-domains
Realm name: pne.qe
ipa: ERROR: an internal error has occurred

error_log 
    [Mon Sep 12 19:32:04.274209 2016] [:error] [pid 9368] ipa: ERROR: non-public: AttributeError: 'NoneType' object has no attribute 'info'
    [Mon Sep 12 19:32:04.274237 2016] [:error] [pid 9368] Traceback (most recent call last):
    [Mon Sep 12 19:32:04.274240 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line 366, in wsgi_execute
    [Mon Sep 12 19:32:04.274243 2016] [:error] [pid 9368]     result = command(*args, **options)
    [Mon Sep 12 19:32:04.274245 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 449, in __call__
    [Mon Sep 12 19:32:04.274247 2016] [:error] [pid 9368]     return self.__do_call(*args, **options)
    [Mon Sep 12 19:32:04.274249 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 477, in __do_call
    [Mon Sep 12 19:32:04.274251 2016] [:error] [pid 9368]     ret = self.run(*args, **options)
    [Mon Sep 12 19:32:04.274253 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 799, in run
    [Mon Sep 12 19:32:04.274255 2016] [:error] [pid 9368]     return self.execute(*args, **options)
    [Mon Sep 12 19:32:04.274257 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/trust.py", line 1765, in execute
    [Mon Sep 12 19:32:04.274259 2016] [:error] [pid 9368]     res = fetch_domains_from_trust(self.api, trustinstance, **options)
    [Mon Sep 12 19:32:04.274261 2016] [:error] [pid 9368]   File "/usr/lib/python2.7/site-packages/ipaserver/plugins/trust.py", line 1647, in fetch_domains_from_trust
    [Mon Sep 12 19:32:04.274263 2016] [:error] [pid 9368]     forest_root_name = trustinstance.remote_domain.info['dns_forest']
    [Mon Sep 12 19:32:04.274265 2016] [:error] [pid 9368] AttributeError: 'NoneType' object has no attribute 'info'
    [Mon Sep 12 19:32:04.274521 2016] [:error] [pid 9368] ipa: INFO: [jsonserver_session] admin@TESTRELM.TEST: trust_fetch_domains/1(u'pne.qe', version=u'2.213'): AttributeError
    s4_tevent: Added timed event "tevent_req_timedout": 0x7fb328864990
    signed SMB2 message
    s4_tevent: Schedule immediate event "tevent_queue_immediate_trigger": 0x7fb32afe3fb0


Expected results:
Should work without any error.

Additional info:

Comment 4 Martin Babinsky 2016-09-13 13:51:48 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6328

Comment 7 Sudhir Menon 2016-09-16 18:27:41 UTC
Fix is seen.
Verified on RHEL73 using 

ipa-server-4.4.0-12.el7.x86_64
ipa-server-trust-ad-4.4.0-12.el7.x86_64

[root@master ~]# ipa trust-fetch-domains
Realm name: pne.qe
----------------------------------------------------------------------------------------
List of trust domains successfully refreshed. Use trustdomain-find command to list them.
----------------------------------------------------------------------------------------
----------------------------
Number of entries returned 0
----------------------------

Comment 9 errata-xmlrpc 2016-11-04 06:03:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.