Bug 1375277 - releasever in baseurl translated to major.minor, not just major (7.3 instead of 7, yum incompatibility)
Summary: releasever in baseurl translated to major.minor, not just major (7.3 instead ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: epel7
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1346063 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-12 15:20 UTC by David Jaša
Modified: 2018-04-11 07:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-30 17:37:58 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Jaša 2016-09-12 15:20:19 UTC
Description of problem:
On RHEL 7, yum replaces $releasever in baseurl= with major version, e.g. 7. OTOH, dnf replaces releasever with major.minor

Version-Release number of selected component (if applicable):
dnf-0.6.4-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. have some repo with $releasever in baseurl/mirrorlist
2. yum makecache
3. dnf makecache

Actual results:
either yum or dnf fails

Expected results:
yum and dnf work consistently

Additional info:

Comment 2 David Jaša 2016-09-12 15:44:43 UTC
In-system release info

# rpm -q --provides redhat-release
package redhat-release is not installed

# ls -l /usr/lib*/*-release
ls: cannot access /usr/lib*/*-release: No such file or directory

# ls -l /etc/*-release
-rw-r--r--. 1 root root 522 Aug  9 16:12 /etc/os-release
-rw-r--r--. 1 root root  62 Aug  9 16:12 /etc/redhat-release
lrwxrwxrwx. 1 root root  14 Aug 16 14:18 /etc/system-release -> redhat-release

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux Workstation"
VERSION="7.3 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.3"
PRETTY_NAME="Red Hat Enterprise Linux Workstation 7.3 Beta (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:beta:workstation"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.3 Beta"

# cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 7.3 Beta (Maipo)
[root@cihla ~]# ls /etc/*-release

Comment 3 Michael Mráka 2016-09-13 10:42:58 UTC
Fixed in
https://github.com/rpm-software-management/dnf/pull/606

Comment 4 Michael Mráka 2016-09-13 11:58:24 UTC
*** Bug 1346063 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.