Bug 1375416 - Default proxy configuration does not cover maven.org
Summary: Default proxy configuration does not cover maven.org
Status: CLOSED DUPLICATE of bug 1321101
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Wang Haoran
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-13 03:57 UTC by Peter Larsen
Modified: 2017-02-18 00:48 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-18 00:48:26 UTC


Attachments (Terms of Use)

Description Peter Larsen 2016-09-13 03:57:49 UTC
Description of problem:

When running a build on a server using http_proxy, only the connection profile that covers maven.repository.redhat.com is applied to the proxy. Any other connection is left "un-proxied" and will fail. 

Version-Release number of selected component (if applicable):

3.2.1.*

How reproducible:

Install OpenShift 3 with Proxy on a network where there's no direct internet access outside the proxy server. Do a default build of an eap7 or tomcat application. 


Actual results:

I0912 23:52:46.923851       1 docker.go:529] Base directory for STI scripts is '/usr/local/s2i'. Untarring destination is '/tmp'.
I0912 23:52:46.923861       1 docker.go:599] Creating container with options {Name:"" Config:&{Hostname: Domainname: User: Memory:0 MemorySwap:0 MemoryReservation:0 KernelMemory:0 CPUS
hares:0 CPUSet: AttachStdin:false AttachStdout:true AttachStderr:false PortSpecs:[] ExposedPorts:map[] StopSignal: Tty:false OpenStdin:true StdinOnce:true Env:[OPENSHIFT_BUILD_NAME=eap
70test-2 OPENSHIFT_BUILD_NAMESPACE=proxytest OPENSHIFT_BUILD_SOURCE=https://github.com/jboss-developer/jboss-eap-quickstarts.git OPENSHIFT_BUILD_REFERENCE=7.0.0.GA HTTP_PROXY=http://pr
oxy.rhdemo.net:3128 HTTPS_PROXY=https://proxy.rhdemo.net:3128 NO_PROXY=.cluster.local,.rhdemo.net,proxy-master1.rhdemo.net,proxy-node1.rhdemo.net,proxy-node2.rhdemo.net,proxy-node3.rhd
emo.net http_proxy=http://proxy.rhdemo.net:3128 https_proxy=https://proxy.rhdemo.net:3128 no_proxy=.cluster.local,.rhdemo.net,proxy-master1.rhdemo.net,proxy-node1.rhdemo.net,proxy-node
2.rhdemo.net,proxy-node3.rhdemo.net] Cmd:[/bin/sh -c tar -C /tmp -xf - && /usr/local/s2i/assemble] DNS:[] Image:registry.access.redhat.com/jboss-eap-7/eap70-openshift@sha256:90d40e219d
688ae32a5f043ce384a753048f0b3b9cb3b569d84804d4e69ad32f Volumes:map[] VolumeDriver: VolumesFrom: WorkingDir: MacAddress: Entrypoint:[] NetworkDisabled:false SecurityOpts:[] OnBuild:[] M
ounts:[] Labels:map[]} HostConfig:&{Binds:[] CapAdd:[] CapDrop:[KILL MKNOD SETGID SETUID SYS_CHROOT] GroupAdd:[] ContainerIDFile: LxcConf:[] Privileged:false PortBindings:map[] Links:[
] PublishAllPorts:false DNS:[] DNSOptions:[] DNSSearch:[] ExtraHosts:[] VolumesFrom:[] NetworkMode:container:7bafb3af6655ea066f19286f67ace307bc0f43a65a969b250c197b40bd0e8095 IpcMode: PidMode: UTSMode: RestartPolicy:{Name: MaximumRetryCount:0} Devices:[] LogConfig:{Type: Config:map[]} ReadonlyRootfs:false SecurityOpt:[] CgroupParent: Memory:92233720368547 MemorySwap:92233720368547 MemorySwappiness:0 OOMKillDisable:false CPUShares:2 CPUSet: CPUSetCPUs: CPUSetMEMs: CPUQuota:-1 CPUPeriod:100000 BlkioWeight:0 Ulimits:[] VolumeDriver: OomScoreAdj:0}} ...
I0912 23:52:47.242836       1 docker.go:622] Attaching to container "a4527d1e45d23d15019f899c616e92387056ac0158cff05269f5a5575f89782a" ...
I0912 23:52:47.242992       1 docker.go:631] Starting container "a4527d1e45d23d15019f899c616e92387056ac0158cff05269f5a5575f89782a" ...
Found pom.xml... attempting to build with 'mvn -e -Popenshift -DskipTests -Dcom.redhat.xpaas.repo.redhatga package -Djava.net.preferIPv4Stack=true '
E0912 23:52:47.417236       1 util.go:91] Picked up JAVA_TOOL_OPTIONS: -Duser.home=/home/jboss -Duser.name=jboss
Using Apache Maven 3.0.5 (Red Hat 3.0.5-16)
Maven home: /usr/share/maven
Java version: 1.8.0_101, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-3.b13.el7_2.x86_64/jre
Default locale: en_US, platform encoding: ANSI_X3.4-1968
OS name: "linux", version: "3.10.0-327.28.3.el7.x86_64", arch: "amd64", family: "unix"
E0912 23:52:47.596963       1 util.go:91] Picked up JAVA_TOOL_OPTIONS: -Duser.home=/home/jboss -Duser.name=jboss
[INFO] Error stacktraces are turned on.
[INFO] Scanning for projects...
Downloading: https://repo1.maven.org/maven2/org/jboss/bom/jboss-eap-javaee7-with-tools/7.0.0.GA/jboss-eap-javaee7-with-tools-7.0.0.GA.pom
Downloading: https://maven.repository.redhat.com/ga/org/jboss/bom/jboss-eap-javaee7-with-tools/7.0.0.GA/jboss-eap-javaee7-with-tools-7.0.0.GA.pom
Downloading: https://maven.repository.redhat.com/earlyaccess/all/org/jboss/bom/jboss-eap-javaee7-with-tools/7.0.0.GA/jboss-eap-javaee7-with-tools-7.0.0.GA.pom
Downloading: https://maven.repository.redhat.com/techpreview/all/org/jboss/bom/jboss-eap-javaee7-with-tools/7.0.0.GA/jboss-eap-javaee7-with-tools-7.0.0.GA.pom
[ERROR] The build could not read 1 project -> [Help 1]
org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
[ERROR] Non-resolvable import POM: Could not transfer artifact org.jboss.bom:jboss-eap-javaee7-with-tools:pom:7.0.0.GA from/to central (https://repo1.maven.org/maven2): Connection to https://repo1.maven.org refused @ line 104, column 25


Expected results:

Downloads from all URLs should be covered by the proxy definition.


Additional info:

Comment 1 kconner 2016-12-12 17:22:20 UTC
Our images use different environment variables for specifying the proxy, as per the documentation.

https://docs.openshift.com/container-platform/3.3/install_config/http_proxies.html#using-maven-behind-a-proxy

We are adding in support for these variables in addition to the ones we use, initially with the upcoming Java S2I image and then pushed out to the rest.

Comment 2 Ben Parees 2016-12-12 18:22:10 UTC
As a side note, I don't think that content belongs in the openshift docs:
https://github.com/openshift/openshift-docs/issues/3368

Comment 3 kconner 2017-02-18 00:48:26 UTC

*** This bug has been marked as a duplicate of bug 1321101 ***


Note You need to log in before you can comment on or make changes to this bug.