Bug 1375433 - Selection of audio output among <graphics> devices
Summary: Selection of audio output among <graphics> devices
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: libvirt
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Pavel Hrdina
QA Contact: yafu
URL:
Whiteboard:
: 1371243 (view as bug list)
Depends On:
Blocks: 1672981
TreeView+ depends on / blocked
 
Reported: 2016-09-13 06:19 UTC by Milan Zamazal
Modified: 2020-11-23 15:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-23 15:47:24 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)

Description Milan Zamazal 2016-09-13 06:19:22 UTC
Description of problem:

When multiple <graphics> devices are present, only one of them can be selected for audio output. AFAIK this is a QEMU limitation, related to QEMU_AUDIO_DRV environment variable used for selecting the audio output.

Apparently libvirt selects the last <graphics> device in the domain XML for audio output. This mechanism is not documented and is not very clear and robust. It would be better if libvirt could provide better means for selecting the proper device for audio output.

One possibility would be to automatically select the device that works. For instance, while audio output works with SPICE, it's unclear whether and how it can work with VNC and libvirt probably doesn't properly support VNC audio output. So if SPICE and VNC graphics devices are present, libvirt should select the SPICE one for audio output.

Another (or complementary) option would be to provide an attribute to <graphics> element that would allow selecting the device for audio output explicitly, instead of relying on the order of the elements in the domain XML.

Version-Release number of selected component (if applicable):

libvirt-2.0.0

Comment 1 Pavel Hrdina 2017-03-24 08:31:54 UTC
*** Bug 1371243 has been marked as a duplicate of this bug. ***

Comment 3 Pavel Hrdina 2017-11-16 14:32:36 UTC
Upstream patches posted:

https://www.redhat.com/archives/libvir-list/2017-November/msg00492.html

Comment 8 Pavel Hrdina 2020-11-23 15:47:24 UTC
RHV implemented workaround for this issue and because there was no other request for this feature I'm closing this BZ.


Note You need to log in before you can comment on or make changes to this bug.