Bug 1375440 - cleanup script unexpectedly called during smoke tests
Summary: cleanup script unexpectedly called during smoke tests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-13 07:04 UTC by Milind Changire
Modified: 2016-09-13 07:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 07:11:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Milind Changire 2016-09-13 07:04:21 UTC
Job URL for reference: https://build.gluster.org/job/smoke/30578/console

Comment 1 Nigel Babu 2016-09-13 07:11:46 UTC
This was because the bash script had `set -e` and cleanup is called before the test starts. Since the log wouldn't exist, it would fail. The fix was adding an `rm -rf`. See: https://github.com/gluster/glusterfs-patch-acceptance-tests/commit/fc1fdb39c37b2a19c1c6f201a49646c82facb919

Fix committed and deployed to all servers.


Note You need to log in before you can comment on or make changes to this bug.